Libre always shows "Not Responding" after I pasted from my clipboard

Hi Libre Team,

I am using LibreOffice in my job and studying. I like it but sometimes i got problem with it.

Please see my step to get the bug:

-Environment: Win 7 64 bit, LibreOffice 3.4.2 -OOO340m1 (Build:203)

-Test case:

Step1: Copy some table in the sheet 1.

Step2: Move to the sheet 2.

Step3: CTR+A to select the whole of sheet2.

Step4: CRT+V to paste.


Pasting is successfully.


LibreOffice got Not Responding.

Thanks for your concern to my question. Please don’t hesitate to contact me if any.


I assume you are using Libreoffice Calc.

When I tried this I got the same result as you. Libreoffice became unresponsive. Looking a little deeper I see that Libreoffice was running and using a high percentage of CPU time and an increasing amount of memory. I believe that Libreoffice was trying to paste the copied cells to the whole available sheet (you used Ctrl-A to select the whole sheet). This is a huge number of cells. I suspect that Libreoffice would run out of memory before finishing.

So…either skip step 3 and LibreOffice will paste the copied cells once, or select a block of cells in step 3 and LibreOffice will paste the copied cells into the selected cells to the extent that it can.

Maybe it is in relation with this bug:
Calc freezes if all cells are marked as selected and one right-clicks on it

I don’t think so. The referenced bug applies to LO 4.2. I’m running and the bug is said not to apply to the 4.1 branch. And I don’t see this bug behavior.