Libre Calc csv file

I have done the CSV file with libre calc, (copy and pasted from xlsx sheet). but when I open that file in ms office two columns came into 1 column, why did this happen?

Read these guidelines and ask a good question. In particular:

— What were the options used when you saved the file?

— How did you open the file in Microsoft Office?


why did this happen?

because MS Office Excel did not understand the column separator you choose (or being used by default, if you didn’t specify) when creating the .csv file. To get full control of what will happen:

  • Click [x] Edit filter settings in file save dialog
  • And select a “Field delimiter” MS Excel understands (probably using ; is a better choice)


  • Advice MS Excel to accept a comma (,) as field delimiter using Data -> Text to Columns... (may be slightly different since I got neither a new Excel version nor an English version of Excel)

Remark: The whole confusion occurs, since there no format definition, what a .csv excactly is.

With one column there isn’t any field separator written.

Understand. Thank you so much.

No error in Calc.

If you open the .csv file with Excel, this program has its own import dialog, which allows you to configure separators, content format, etc., with its corresponding preview.