Libre office 4.1.3 won't install

My system is Windows 7. The installer fails with:
“The older version of LIbre Office can be uninstalled.”
It’s looking for this:
C:\Users\glenn\AppData\Local\Microsoft\Windows\Temporary Internet Files\Content.IE5\ILR4BKZU\

which doesn’t exist. I can’t uninstall from Windows “Programs and Features” because it says the msi file doesn’t exist. (true)
My current working version is 4.0.3 which is the last successful upgrade I have been able to do.

Error 1714.
“The older version of LibreOffice can’t be removed”
I deleted everything by hand, removed everything from the registry and determined I do not have quickstart running on my machine.

What next?

You might consider cleaning your registry before installation. Of course don’t forget to backup, copy machine, files and registry-file before attempting to do anything with it.

I cleaned the registry of EVERY value including LibreOffice after I got the same exact error. I tried repairing the installation prior to cleaning the registry, but I didn’t have the version MSI file and couldn’t find the archive (found now). I don’t know if 4.1.3 did the damage or if it was already corrupted. It was working fine the last time I used it. I think I had installed prior to this mess. Can’t install any LibreOffice version now. I am dead in the water. Any links on Registry Cleaning to make sure I got rid of all the entries???

Problem solved for the time being… Painless install of Open Office met my needs!