Libre Office 6 base crashes when left undisturbed

When running base in Libre Office (on Windows 10) I noticed that the program semi-dies after a while when left undisturbed. Before that I had not done anything fancy, just added rows to some tables, or changed some rows’ content.

What I mean by semi-dies is that the progam is still running, but it does not do anything. When hovering over one of its windows it enlarges it slightly, but clicking on it does not show the window, it does nothing.

Fortunately, it does not delete the tables, but the latest changes are lost when I kill the program.

When I restart the program it goes into an unrecoverable tailspin, unless I delete myself the lock file of the crashed database beforehand.

Please test with a clean profile Menu/Help/Restart in Safe Mode.

I tried that. Same thing. Left that undisturbed for a few hours, now it’s semi-dead again - in safe mode. To be honest, I expected that, as this is a fairly recent out-of-the box installation, with standard settings. Of course, I had installed a JRE, otherwise base is not operational. But the thing that the windows are there but not responding suggests that something with the GUI has gone wrong.


Have tested on Ubuntu 18.04 Mate with LO v6.4.2.2 (TDF). First run over two hours undisturbed no problem. Next day over four hours undisturbed and again no problem. This with a form open and just sitting. After the specified time all worked as normal. No other LO items were active or run during these tests.

This should be opened as a bug report in Bugzilla:

While resetting the profile might help sometimes, this looks like a real bug. Hopefully this is reproducible by others, even if you need to wait a few hours.

I have a suspicion of what might have been going on. I was tired of LibreOffice suddenly dying on me, so I installed OpenOffice too. Thing was: OpenOffice did not recognize the presence of a JRE, although one was clearly installed. However, I had done a default JRE installation and as I have a 64bit machine that must have been a 64bit JRE, and OpenOffice rejects those, it does require 32bit JREs. Perhaps LibreOffice base also has a problem with 64bit JREs, but it does not reject them outright from the start.


Can’t say just where your problem exists. However, with Java (JRE) since Open Office is 32-bit only it requires a 32-bit JRE. With LO it can be either a 32 or 64 bit version and the JRE must match bitwise. So a 64-bit LO requires a 64-bit JRE.