Libre Office 7.4 cannot access data

I have just updated my LO from 7.0.6 (installed from the Ubuntu Software Center) to version (also from the Ubuntu Software Center). I say update but I actually uninstalled 7.0.06 and installed fresh. However, when I try to open a document from Files or Double Commander, I get an error that says “Access to {full path} was denied”

If I try to open the document from a program, e.g. Writer, when I click on the relevant directory I get the error “Error opening directory {path}. Permission denied”

The documents are stored on a separate internal hard disk, mounted as read-write, and all permissions are rwxrwxrwx. Obvious really as everything worked fine for 7.0.6 Also I am using Ubuntu 20.0.4

What have I forgotten to do?



Do yourself a favour and stick to the orignal LO 7.0 version of your distribution. 7.4 has a lot of bugs and the container versions (flatpak etc) are poorly integrated.

Thanks, that was good advice!

Have reinstalled 7.0.6 and all my data files are accessible again.

Thanks again

In case of Ubuntu it’s Snap though, not Flatpak. I dare to say that the Flatpak build is better integrated than Snap, but the sandbox requirement of both will always result in a balance between restrictions and allowances. Anyhow, 7.4.1 is very fresh, wait for 7.4.3 or start with an interim 7.3.6 if you really want to use a container version (the Ubuntu Software Center apparently offers Snap packages without making it obvious).

What is {full path} by the way?
These container packages are a true benefit for the package maintainers but they have nothing to offer to the users. If you are really interested in the latest version (I’m not), download the 7.4 dpkg from

Thanks for the response.

I’ll probably stick with 7.0.6 as it does everything I need to do. Maybe if/when I update to Ubuntu 22.0.4 LTS I might try an updated Libre Office. Suspect that won’t be in the very near future :smile:

the path is /home/Data/Documents/{every directory} where /home is on the root filesystem and Data is a separate internal disk.

A new install of 7.0.6 happily accessed my files whereas 7.4 didn’t. So as I don’t need the latest bells and whistles, I’ll stick with the older version.

Note that instead of the Snap thing there are several Ubuntu package repositories for LibreOffice, main for various Ubuntu releases of which you may want the now current 7.3.6 from backports, and the PPAs with further builds of which you may want the LibreOffice Still repository’s version.

Until 7.5.5 (Ubuntu 23.04), the path /media/john/MyDocuments worked. MyDocuments resides in an EXFAT partition of my SSD, and also works fine when I boot Win11 instead of Ubuntu. Now LibreOffice Writer cannot find /media/john/Documents/. John

This path

is not the same as