Watermarks in Calc

v6.4.7.2 Linux
I have created a watermark on a spreadsheet, but now I cannot find what menu it is under - I thought it was Edit but now its not there! Where can I find it?
See attached spreadsheet, with watermark “C O P Y”

INVOICE - COPY noaddress.ods (21.3 KB)

It seems to be just a text box, so Insert > Text Box, Adjust text size, colour and rotation. You can double-click the text to select all the text and click Format > Character > Font Effects > Transparency and set to 40% so you can see underlying text. Note that it will appear on only one page.
You might do better to recreate it in Draw, convert it to a bitmap and set transparency to 50%. Export selection as .png. You can then insert the image into your spreadsheet and it won’t obliterate everything under it. You could instead anchor it as background but it will be hidden behind coloured cells. Selection would then have to be done through double-clicking the CopyBackground name in Navigator sidebar. Attached sheet with Text box as given, Copy image as background and Copy image floating.

INVOICE - COPY noaddressEA.ods (32.0 KB)

Some printers can add a watermark in the printer driver settings.


Menu / Format / Page Style / Background tab/Image button.
INVOICE - COPY noaddress 2.ods (29.2 KB)

1 Like

Thanks, but have to make image first then adjust it to fit the page.

Yes, you are right! That’s how I did it. But I can’t see a Transparency option under font effects in the Text Box.
I will try your other suggestion later but text box would be easier if I could find transparency.
I must have seen the Watermark option in a dream!!

Version: (x86) / LibreOffice Community
Build ID: 184fe81b8c8c30d8b5082578aee2fed2ea847c01
CPU threads: 8; OS: Windows 10.0 Build 22000; UI render: Skia/Raster; VCL: win
Locale: en-GB (de_DE); UI: en-US
Calc: threaded

Here is what I get - no transparency option. Could I somehow have removed the option by mistake?

Yes, it is this way --edit (I also don’t get transparency) /edit-- in…

Version: (x86)
Build ID: 639b8ac485750d5696d7590a72ef1b496725cfb5
CPU threads: 4; OS: Windows 6.1 Service Pack 1 Build 7601; UI render: default; VCL: win;
Locale: es-MX (es_MX); UI-Language: en-US
Calc: threaded

1 Like

Not in my

Build ID: 1:6.4.7-0ubuntu0.20.04.4
CPU threads: 4; OS: Linux 5.4; UI render: default; VCL: gtk3;
Locale: en-IE (en_IE.UTF-8); UI-Language: en-US
Calc: threaded

That’s what LeroyG said, it’s not in 6.4.7.

yes i know. thank you.

PKG has the Windows version in, and that has the transparecny option.
For Linux LO the latest version available in the Ubuntu repositories is is the latest version.
7.4.1 is available from LibreOffice as a .deb file but I couldn’t get it to install.

I’m sure I had the transparency option a couple of weeks ago, but that might have been in a dream too!

Just tried LO on a Win machine. As PKG says, the transparecy option is there - and it works fine.
Guess I’ll just have to wait until Ubuntu catches up.

Ahhhhh. Just installed LO using terminal. Transparency option present (in a different place).

sudo add-apt-repository ppa:libreoffice/ppa
sudo apt-get update
sudo apt-get install libreoffice

Thanks to all who replied to my post.

Not really.

1 Like

Thanks. that is useful to know.
I don’t know much about repositories, but wonder why the latest repos are not included in Software Manager. I use Mint and do the updates every couple of weeks using Update Manager.

Maybe because it is not fully supported. I have added the Fresh repo as per the link you gave.
Presumably if you run into problems you just have to purge the repo.