Libre Office Base report design view not working

This seems to be a recurring problem. This did not work in an older 4.2x version Ubuntu 14.04 and it was part of my reason to move my DB to Ubuntu 16.04 LO kernel 4.4.0-81. Base was NOT a part of the regular LO install and I had to download it separately. Selecting the report builder design view does nothing. Any help would be appreciated.

My normal operation is on Mint 18 but I have many other distros mainly for testing. Just switched over to Ubuntu 16.04 with Unity (gave up on this two years ago). Have XFCE also but probably same result.

I agree with the default install about it being in pieces. However changing PPA’s doesn’t help much either. When just now switching over, system was set for using LO v5.3.x from upgraded PPA. I confirm your problem with Report design view. It just doesn’t work. The only selection which worked was the wizard - and that opened in a Writer document! Normally, I will not use ANY distro or PPA version because of experienced problems. Only had here for test purposes.

So, I deleted the PPA version, and having versions lying around directly from LO, I installed v5.3.2.2 (latest I have right now). Opened up same Base file mentioned above and there were no problems opening in design view OR creating one in design view.

Once again, a problem with non LO version of LibreOffice.

If this answers your question please click on the :heavy_check_mark: (upper left area of answer).
FYI - The ^ signifies good answer & down caret not good. The check mark signifies question answered correctly.
These symbols are somewhat finicky so only click on once. Sometimes it may take a few seconds to accept & respond.
These are indicators to others indicating results of the question. They also increase karma (which allows increasing capabilities in the forum) to the recipient.

OK, I can do that but I am concerned about leaving any vestiges of the currently installed LO. Is there a proper (or necessary) procedure to get rid of all the old?

The only thing I did just now was go into “Ubuntu Software”, “Installed” tab, and clicked on the “Remove” button for “LibreOffice” which removed all the installed modules. Long term you may want to remove any PPA you have installed for LO. Finally just installed LO from DEB directory with sudo dpkg -i *.deb. This can be uninstalled with:

$ sudo apt-get remove --purge libreoffice5*

$ sudo apt-get clean

$ sudo apt-get autoremove

when you want to upgrade to a newer version.

OK this worked fine. Let me summarize what I did -

apt list --installed | grep libreoffice | more

apt purge

When I was done there were no LO packages showing installed

Removing any LO ppa’s

download DEB64 package from official LO site


Follow readme to install all packages.

Base report design view now works. Thanks again for a great answer! BTW I use Ubuntu Mate - unity sucks!

You are welcome. I tried Mate today. Might give Ubuntu another shot. Mate provides much more of what I need than Unity or xfce.

I know a lot of time has passed but I wanted to mention that when libreoffice is installed from PPA without Base and then one installs Base by itself (sudo apt-get install libreoffice-base), the separate report-builder is not installed and you get similar issues. So by installing it thus:

$ sudo apt-get install libreoffice-report-builder

You get the missing functionality.

@monachus It seems you are confusing PPA version with distro version. PPA version installs Base by default. Distro versions tend not to install Base.