libre office converted (broke) my .wps files to google files

I updated from LibreOffice 3.5…something or other, to 6.3.0. Previously I had .wps files, which I was told would open with LibreOffice. It converted all of my .wps files to Google Chrome files (?) and now they won’t open. When I click on a .wps file (now Google) it just copies it to my download folder, but it does not open it.

On a side note, the info said the download file would be 286mb. Turns out it’s actually 915mb.

What is your question?

And what are Google files anyway?

On a side note, the info said the download file would be 286mb. Turns out it’s actually 915mb.

Do you count the size of the downloaded file (LibreOffice_6.3.0_Win_x64.msi; 286 MB) plus the size of installed application (in C:\Program Files\LibreOffice; ~640 MB and depends on selected feature set)?

@anon73440385 @erAck -
Oh yeah, my question! I did this update to the more recent version because it said that it could open .wps files, but it doesn’t. HOW do I open these dang files?
The icon/thumbnail for each file is now a Google Chrome logo.

On a side note, thanks @mikekaganski for clearing that up.

LibreOffice can open .wps files but it seems your file associations have been messed up by some unkown action, which got nothing to to with the installation of LibreOffice. I suggest you do not double click on one of your .wps files but right click and select “Open with ..” and select LibreOffice Writer from the application list an thus selecting the app to start for opening .wps files. Do not forget to tick Always use this app for .wps files (if you are on Windows 10 - you did not mention your os at all),

@anon73440385 I’m going to give that a try.
I’m using Windows 7 Pro.

@anon73440385 (and @Mike2 Kaganski) That worked! Merci beaucoup. When I installed the new version, Google Chrome decided to make itself the default program. I now have it set to default to LibreOffice. Thanks again :slight_smile:

LibreOffice can open .WPS (MS Works) files. But it does not associate itself with those files automatically; if you had that association previously, then you must have done that yourself (even if you did that unconsciously, e.g. answering somewhere “Open these files with LibreOffice -Always”). But then you upgraded, the old version got uninstalled, removing the old association; the other application on your system that claims to be able to open those files (Google Chrome?), or the one that you tried to use to open them (and also kept the “Always” checkbox?), is now associated with them.

You may open those files from LibreOffice itself: open the application; use “Open” button/menu; and select the files you need from the dialog.

Or you may look this Ask site for the many question about file associations (type associate files windows in the Search box at the top, and press Enter), to learn how to manage file associations on your operating system.

Merci Mike :slight_smile:

Right click on the file you wish to open and select “Open with”, scroll down and select “Choose default program…”, then select LibreOffice from the list of “Recommended programs.”