Libre Office crashes

Since yesterday, LibreOffice crashes every time I open it. I can open a document, although it takes rather long, but as soon as I try to do something in it (click anywhere, search with Control-F) the program crashes: it ‘doesn’t respond’. If I wait, it ‘responds’ again after some time, but if I then try again to do something, it crashes again. Libre Office Calc crashes too, in the same way. Even if I go to Start → LibreOffice → right click → Properties, the program crashes.

I tried downloading the updated version today, but the problem remains. I can’t think of anything I did yesterday or the day before that might have caused it, didn’t visit any dodgy sites or anything.

I’m on a laptop, Windows 8. Libre Office version 5.4.2, before I updated I had a slightly older (few months) version.

Any help is very welcome!

Have exactly the same problem. First experienced it when I upgraded to 5.3.7. When I tried to switch back to 5.3.4, the same thing occurred. Can’t find any remedy online so unfortunately had to switch to WPS office which is useful and prettier but not as comprehensive.