Libre office crashing since 7.2.5 version


I’m using Libre office for performance testing along with Apptimer which is opening and closing Libre office and measuring the time it takes to display window with certain title, so far i have been using libre 7.1.2 with no problems but since i updated to 7.2.5 it started crashing. I’ve also tried versions 7.3.0 and 7.3.1 but the result is the same.

I’m using windows 10 x64 build 19044.1586 21H2

Here’s the link for the dump 2e1abeb8-0210-4ae0-853b-017e41c6c25f.dmp - Google Drive

Can someone please help me find out what is the issue here ? I really need to use recent version of libre office.

Thank you for any answer

Try First steps

There Step 2.

Hi @Hrbrgr,

thank you for your answer but user profiles shouldn’t be a problem, i forgot to mention that there are another steps taken before this test proceeds and that is always a fresh installation of Libre office on clean image. I think it would be best to look at the dump a see what caused the crash exactly but i’m no dev so i have very little experience in analyzing dumps :confused:

Yes, we both have a problem with reading dump files.
I am not a developer either.
You are here on a site where users help other users.

I can still give you general advice about installing on Windows 10 systems and what issues there might be then:

General Installation Issues (Windows)

…testing along with Apptimer…

I assume that this is an automated process. Therefore my question: Have you tried to start LibreOffice manually?

1 Like

Stack overflow in Skia. As a workaround, disable Skia. But it must be filed as a bug, you should not expect developers to see it here, and be able to improve anything without proper bug report :slight_smile:


Great ! Thank you for having a look, i will file it as a bug for sure, in the mean time is it possible to launch LO with openGL disabled through parameters at runtime? I found that on linux you can set some environment variables but not sure of the name and value.

Thanks again !

1 Like

It’s not OpenGL, Skia works either in Vulkan mode, or using software rendering.

To disable it, start in Safe Mode (if you can open the program at all, it’s available in Help menu; otherwise, see here).