libre office keeps stating that I have no java JRE when I do?

I realise this question has been asked several times but mine is defintely unique and you will see why when you take a look at the attached jpegs. I am not trying to do anything special with Libre Office like some other posters have commented in the past, merely use it for viewing documents like docx converting to pdf which is a fantastic feature btw and thats about it. However every time I open it it shows the LO requires a 64bit JRE etc etc dialogue which isn’t really an issue as the program still opens, it’s just highly annoying as every single time I have to press ok just to get the stupid dialogue out the way!!! I have Windows 10 Pro 64 bit version 17763 and Running Libre Office Version: (x64)
Build ID: 747b5d0ebf89f41c860ec2a39efd7cb15b54f2d8
CPU threads: 4; OS: Windows 10.0 Build 17763; UI render: default; VCL: win;
So both 64 bit arch however even though I have tried several times to download 64bit Java JRE it would appear according to my system that I have in fact 32 bit java installed? so something odd is going on with Oracle supplying the wrong files at point of download. I came across a post somewhere on this forum can;t recall now but it mentioned that it was abrowser issue with Firefox causing plugin malfunction on Oracle site so it is unable to automatically detect your systems requirements or architecture, this is what I hate about automatesd systems which don’t actually seem to work properly! Why can’t sites just provide the files like the site used to where you choose which flavour you want to download, it’s not rocket science to know the architecture of your system and then download accordingly? I realise that 64bit systems can run 32 bit programs but not the other way round but maybe there is a bug or something not quite adding up. Also when I go to Tools/Options/Advanced in LO there is no JAVA JRE detected even though I know for a fact that JRE is installed as you too can see from the last screenshot provided, so what the hell is going on? it’s very weird??! So if anyone has had the same thing occur to them with the latest version of Libre Office on Windows 10 Pro build 17763 and has found a solutio please do let me know becasue this persistent pop up is highly annoying! Thank you in advance. And don’t say I haven’t provided enough info because I think I have gone above and beyond if you read my post properly and view screenshots. image description

From your Java environment it is x86 not x64 like your LibreOffice version.

FAQ. There’s no “issue with Firefox causing plugin malfunction on Oracle site”: Oracle simply doesn’t even try to detect your architecture, and always suggests 32-bit Java.

The question is - why the request at all. Likely you have some extension (e.g., LanguageTool) that requires it. Otherwise, that would look like a bug.

but mine is defintely unique

Lol :slight_smile:

@MIKE Kaganski thanks that is kinda what I thought. Could it be a problem with my actual specific machine? I have had known issues with certain programs like Advanced System Clear and it’s associated bundle of programs sometimes show odd resolution behaviour like showing up tiny when they do something like an update and then when I run them again, back to normal? Maybe resolution or a windows driver is creating the issue? Wouldn’t be the frist or the last time Windoze drivers have caused weird behaviour? Or an HP laptop for that matter! Oh well I suspect I’ll never find out and just have to put up with the annoying pop up as it doesn’t casue any issues for me work wise just slows process down a little and causes slight annoyance so I can’t really warrant wasting any further time on it as counter productive. :slight_smile: unless of course something happens in the future of course!? thanks anyway for your prompt response.

Have you read the FAQ where it’s described? No local problem yet expected - you just download from a wrong place.


You can download offline installer of Java.