Libre office not starting in Debian Buster/Testing

Using Debian testing and uograded a few days ago.
jp@OSUCHSA227:~$ uname -r

Most aps are launching Ok; exceptions VLC and Libreoffice, systems tools in Cinnamon failure seems a know problem.

LO would flash a banner then not open any of its components under Cinnamon or Xfce.
Removed it with Synaptic along with other files connected (e.g. libboost).

Does have java
jp@OSUCHSA227:~$ java -version
openjdk version “11.0.4” 2019-07-16
OpenJDK Runtime Environment (build 11.0.4+11-post-Debian-1)
OpenJDK 64-Bit Server VM (build 11.0.4+11-post-Debian-1, mixed mode, sharing)
Downlaoded the most recent stable, but gdebi opened multiple windows on the group of *debs and failed.

Tried the snap of
jp@OSUCHSA227:~$ libreoffice --version
LibreOffice a887734edd14b7c31b8ab527c0422d03c5e16f8b
Icons appear in menus. But, this shows the cycling icon, then also fails to start under Cinnamon, or Xfce from menus (no cycling just fails). Checked permissions and the ones I checked are world executable.
jp@OSUCHSA227:~$ snap find libreoffice
Name Version Publisher Notes Summary
libreoffice canonical✓ - LibreOffice is a powerful office suite including word processing and creation of spreadsheets, slideshows and databases
projectlibre 1.9.1 jibel - Project Management software - alternative to Microsoft Project

So if even the Snap fails, what should I do ?


More information:
Linux version:
jp@OSUCHSA227:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Debian
Description: Debian GNU/Linux bullseye/sid
Release: testing
Codename: bullseye

jp@OSUCHSA227:~$ snap info --verbose libreoffice core
name: libreoffice
summary: LibreOffice is a powerful office suite including word processing and creation of spreadsheets,
slideshows and databases
publisher: Canonical✓
contact: Bugs : libreoffice package : Ubuntu
license: unset
description: |
LibreOffice is a powerful office suite – its clean interface and feature-rich tools help you
unleash your creativity and enhance your productivity. LibreOffice includes several applications
that make it the most powerful Free and Open Source office suite on the market: Writer (word
processing), Calc (spreadsheets), Impress (presentations), Draw (vector graphics and flowcharts),
Base (databases), and Math (formula editing).

  • libreoffice.base
  • libreoffice.calc
  • libreoffice.draw
  • libreoffice.filebug
  • libreoffice.impress
  • libreoffice
  • libreoffice.math
  • libreoffice.writer
    private: false
    confinement: strict
    devmode: false
    jailmode: false
    trymode: false
    enabled: true
    broken: false
    ignore-validation: false
    base: core18
    snap-id: CpUkI0qPIIBVRsjy49adNq4D6Ra72y4v
    tracking: stable
    refresh-date: today at 08:47 CDT
    stable: 2019-07-31 (137) 439MB -
    candidate: 2019-07-31 (137) 439MB -
    beta: ↑
    edge: ↑
    installed: (137) 439MB

name: core
summary: snapd runtime environment
publisher: Canonical✓
license: Other Open Source
description: |
The core runtime environment for snapd
private: false
confinement: strict
type: core
snap-id: 99T7MUlRhtI3U0QFgl5mXXESAiSwt776
stable: 16-2.39.3 2019-06-27 (7270) 92MB -
candidate: 16-2.40 2019-07-17 (7396) 92MB -
beta: 16-2.40 2019-07-12 (7396) 92MB -
edge: 16-2.40+git1422.97ff46c 2019-07-31 (7516) 93MB -

LibreOffice as Snap | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft was the source of the SNAP
They say "Snaps are fast to install, easy to create, safe to run, and they update automatically and transactionally so the application is always fresh and never broken. "

Thanks for the idea of a flatpack. I will look into it; rather it work than a fresh install.

Apparently you tried the snap from Canonical on Debian, I don’t know if that is even supposed to work and I would not recommend. You could try the Flatpak instead, see LibreOffice in Flatpak format | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft

However, you could also install a regular .deb in parallel, see

While the snap did not work, the LibreOffice flatpack I downloaded today from their site (Flathub—An app store and build service for Linux) after the simple instructions for using apt to install the flatpack software, did install, be seen by the menu system after reboot, and launched properly.

I hope they get the problem in the repo install/update fixed. I have been spoiled by how well Debian testing has been smooth for years over many update/upgrades.

I do not know how to relay this experience to them. Feel free if you know, or tell me.