LibreOffice 3.5.4 "Base" keeps crashing

The Base application dies on me during opening. It doesn’t matter if I try to open an existing database or create a new one. I hit the finish button, it then opens the dialogue to select folder/file name for database, allows me through the process to name and accept; then the app hangs for a bit, says it’s failing and the only option becomes to let the app close giving me the error “libreoffice 3.5 has stopped working”

The event log shows a failure to pass correct arguments to one of the visual c libraries, event displayed below. I have tried removing, rebooting, reinstalling the application. I’ve cleaned out and reinstalled the VC library as well to no effect.

Suggestions would be welcome.

Faulting application name: soffice.bin, version:, time stamp: 0x4fbc7fd1
Faulting module name: MSVCR90.dll, version: 9.0.30729.6161, time stamp: 0x4dace5b9
Exception code: 0xc0000417
Fault offset: 0x0002e9f4
Faulting process id: 0xed0
Faulting application start time: 0x01cd53a75fddce3d
Faulting application path: C:\Program Files (x86)\LibreOffice 3.5\program\soffice.bin
Faulting module path: C:\Windows\WinSxS\x86_microsoft.vc90.crt_1fc8b3b9a1e18e3b_9.0.30729.6161_none_50934f2ebcb7eb57\MSVCR90.dll
Report Id: a6527f37-bf9a-11e1-8fad-00248c0400c1

Similar to this bug: - same fault offset, same exception code. Maybe you can improve that (incomplete) bug report on bugzilla? Additionally, you could add some details (win 7 or win7 64? Java version?).

another detail: did you try to rename your LibreOffice user profile so LO starts with a new, clean profile?

See also LibreOffice crashes on opening

I also had this problem whenever I opened a Base document. I tried to reset the user profile by going into Office->Tools->Options->LibreOffice->UserData and updating the information there. That is not what is meant by resetting the user profile.

Through a little searching, I found this page:

Read section 2 to find out where the user profile is on your machine, then read section 3 to find out how to reset it.

It worked great for me. YMMV.

Same problem. Upgrading to did not help.
Workaround: Try the portable version:

Same comments as above: did you try to reset the user profile?

Regarding bugs mentioned by @tohuwawohu,

  • Current status of fdo#48271 - base crashes - is RESOLVED DUPLICATE of bug 38913
  • Current status of fdo#38913 - CRASH at startup citing msvcr90.dll after upgrade (most likely related to javasettings_Windows_x86.xml in the user profile) - is RESOLVED FIXED.

It sounds like this bug may be fixed. If it does NOT appear to be fixed, please reopen one of the existing bugs or file a new bug, and provide a list of steps that can reproduce it. The QA team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format “fdo#123456”.