LibreOffice 3.5 spellcheck not working

Hi, I have Windows 7 (64 bit). I installed the new 3.5.1 and spellcheck is not working. I went through this troubleshooting tutorial: but it didn’t help - Spellchek is set to english US, however the dictionary is wrong as the documents is all red. How can I fix this?

I had to uninstall and reinstall to fix this. There’s probably a more elegant way though.

Thanks for replying MegaTallDave,
I have already unistalled, deleted all folders related to libreoffice and reinstalled the software. Unfortunately didn’t work for me.
It must definately be a better way to fix this :slight_smile:

To fix this, I had to go into Program Files/LibreOffice 3.5/Share/Extensions and delete ALL the dictionaries except English. Then, spell-check worked. Even though my default styles and language settings were all correct, until I deleted the other languages words like “Much” and “The” were showing up as mis-spelled. No amount of configuration setting would fix that issue.

My spell-check was overzealous. Words like “The”, “Our” and “Much” were misspelled. It wanted to correct “Much” to “Muit”

I checked ALL the configuration settings. All set to US English. I had to go into the program folders and delete the other dictionaries to get it to work right.

I just installed 3.5.3 afer uninstalling OO. I did what the person below stated: go into Program Files/LibreOffice 3.5/Share/Extensions and delete ALL the dictionaries except English (en). Then, spell-check worked. thank you.

Recently installed LibreOffice 3.4.4 would not perform any spell-checks in english-gb or custom dictionaries. Previously I have had no bother with any installment.
Discovered by installing myspell-en-gb 1:3.3.0-2ubuntu3 english spell check worked as well as 6 custom dictionaries of many thousands of words.
Happy again, hope this helps.

I did the same as above and it worked. However, this is not a satisfactory method to make things work. I had hoped to use this program in teaching my computer classes but do not think it would be a good idea until this bug is fixed.