Libreoffice 3.6.0 always crash after install. Why?

Hello. I was very happy with LibreOffice 3.5.4, and did not know I was happy! So, uninstalled version 3.5.4, downloaded and installed version 3.6.0. Then my problems started.

I always have problems in start the program. The system return a popup message:
Fatal Error. Unhandled exception: InvalidRegistryException: file///C:Program%20…

Now, I no longer have the installers of the stable version 3.5.4

I think you should try at least test the program before releasing it to the public. This would avoid this embarrassing fiasco.

I think my solution is to download Apache OpenOffice 3.4.0, and try to be happy again!

It has been suggested numerous times here that deleting the user profile is a solution to this problem. See a description on how to do this here:

For those considering the solution of deleting the user profile, I’d like to add that in my case it was sufficient to delete the “extensions” subdirectory of the user profile. This might be handy information for people who want to keep most of their user profile and still update.

If you don’t care about the user profile (you may need to set some settings again the way you want them), you can safely delete it though.

See also → LibreOffice fails to start after update – UNO Exception: InvalidRegistryException: … duplicate …

Related bugs: • fdo#53006 • fdo#51252 • fdo#43989 • fdo#50552 — removing the directory "extensions" (see above) should be a sufficient workaround. The bug will be fixed in version 3.6.1.

Fixed in LO 3.6.1

Same problem here. Windows 7 Home Premium 64bit.
After the first error-message there is a second one:

Microsoft Visual C++ Runtime Library
Rutime Error!
Program: C:\Program Files (x86)\LibreOffice 3.6 […]

same problem:
unhandled exception:
file:///C:/Program%20Files/LibreOffice%203.6/program/…/share/extensions/NLPSolver/components.rdb: duplicate


Microsoft Visual C++ Runtime Library
Runtime Error!..

Have exactly the same issue.

Unhandled exception:
Invalid Registry Exception:

The solution is here: link text

You need to change the user profile in app data…Unfortunately you have to migrate the data but the software will work.

Same problem here. I agree you should test before releasing to the public. It is like you trying to promote moving users back to Microsoft instead of receiving the benefits of LO. By the way the previous version was crashing for not finding Java which was install. I thought that with this update my problems were gone. On the contrary they worsen.

Now is a new message after rebooting the computer. In the process of starting the application when it was one forth of loading its file a popup says: “LibreOffice 3.6 stopped working. A problem caused the program to stop working correctly. Windows will close the program and notify you if a solution is available”. And that’s it. You are on your own. I’m running Windows 7 Ultimate 64 bit. Please guys, solve the problem ASAP. This is not a game. You promote this product as a trusted program for a lot of institutions and this is what we got? Please there are reports I have to finish and I don’t want to end having to buy Microsoft’s Office package. I can’t believe this is happening.

same problem here… the link above to the user profile things was not helpful. would be great, if someone could provide a solution…

I’m uninstalling 3.6 and I will delete the LO folders left after the uninstall, following the instructions from the link. It will take more than 10 minutes on my W7U 64bit 4Gb RAM. Suggestion since this is not a regular process for a regular user: why not creating a batch file that clean up everything after backing up those personal files and restoring them after reinstalling LO. I hope this will work.

After 19 minutes of installation process of LO 3.6 I received a Microsoft .NET Framework error message. Unhandled exception has occurred in your application. If you click Continue, the application will ignore this error and attempt to continue. If you click Quit, the application will close immediately… and so on… If you want I can paste the Details shown in this window. I will try to Continue and see what’s happening.
I did that and no other pop up message showed up.
I started LO for the first time now. It doesn’t crash on 25% loading. Two minutes after the starting window disappears and I have no clew what is going on. LO icon is not among the running programs. Four minutes and nothing. I decided to go and launch LO again. Five seconds and the main menu shows up. Text document opens, same for Presentation, Spreadsheet, Drawing and Formula. Finally Database shows up not crashing. Congratulations. The instructions on the link, for now, it worked after almost 35 minutes of work. This is an installation to remember.

Got it working on Win 7 32 bit Sp1:

Step 1: I uninstalled all Libre Office.

Step 2: I renamed the folder on Windows 7 from “C:\Users<user>\Application Data\libreoffice\3” to “C:\Users<user>\Application Data\libreoffice\3_OLD”.

Step 3: Resinstalled the 3.6 (Version (Build ID: 932b512)) version.

Step 4: Delete the 3_OLD folder and Enjoy :slight_smile:

Note: You need to permissions to view System Folders or you can just copy paste the path from above. Don’t forget to replace the with your login name.

dont know if it helps anyone
i have installed Libre office 3.6 ok (English-GB Version) no problems at all
over the top of a version i had installed not sure which version that was though
and it runs ok

from libre writer help/about libre office/Version (Build ID: 932b512)

win7 32bit ultimate
afaik no sp1

Here: no problems installing 3.6 with 3.5.5 previously installed, everything works like a charm. I even didn’t need to remove 3.5.5 before installing 3.6. System: Win7 64bit.

As for me, I noticed that LibO 3.6 (RC4, but as far as I understood it became the final version) would always crash silently the first time I launch it after the installation. I.e., I install it, I launch it, see the splash screen load for some seconds then nothing. Then I relaunch it and it works fine (no more startup crashes afterwards, even after rebooting, etc: it’s just the very first post-install launch that 100% failed for me).

Edit: need points to upvote… since this Q&A is pretty new, I guess this is why the question hasn’t been upvoted like 10 times already…

Thanks Marcus, that helped. Deleting the profile was not an option for me, to many settings. But just deleting the extentions folder solved everything.

I have installed v3.6.0 on four PCs (Win 7 32 and 64 bit) and after install, each one has crashed with the same error about ‘Uno’ something or another. The fix was the same in each case and works 100%…just repair the installation.

It’s annoying that after fixing the installer to find the current (user defined) install folder, it now defaults to something else and has to be (once again) manually changed - the help files do not have this issue (they used to).


Yet another solution

I got the error - Unhandled exception: Invalid Registry Exception: file:///C:Program%20Files%20(x86)/LibreOffice%203.6/program /…/share/extensions/wiki-publisher/components.rdb:duplicate

after installing 3.6 from 3.5.3. I tried the usual, reinstall, repair, uninstall, reinstall, reboot but still that error. I also tried removing the 3.6 directory in Program Files(x64)but no luck. I uninstalled 3.6, installed 3.5.6 which worked and then installed 3.6. It worked!