LibreOffice 3.6.1 spontaneously hangs in Mac OS X.6.8

By mistake I had installed the PPC version of LO 3.6.1 on my Intel Mac Pro, and loaded an existing spreadsheet that was saved by NeoOffice. A few seconds after loading, without my hitting any keys or buttons, but moving the cursor, the app hung (spinning beach ball and one CPU goes to 100%).

After force-quitting, I downloaded and installed the Intel version over the earlier one, and then again loaded the same spreadsheet. Again after a few seconds the app hung spontaneously. Finally I deleted the app with AppDelete, and installed it fresh from the .dmg file.

This time I opened a new spreadsheet and tried a couple of elementary things. They worked, so I accessed Preferences and started to look at the General subheading under LibreOffice. After a few seconds, without my doing anything, the app hung.

This happened two more times. Is there any way to get this app working under Mac OS X.6.8?


  • Dushan

Hi @dushanm,

If you’re still having problems with your install, and you’re quite sure that you’ve fully removed the PPC version using AppDelete, please file a bug about this problem, and provide a list of steps that can reproduce it. The QA team will be happy to help you track down this issue!

Please post a link to any bugs you file in a comment below using the format “fdo#123456”.


Before reporting bug, I suggest to install the latest version from 3.6 series, currently 3.6.5 from - this problem may already be fixed.