LibreOffice 3.6 issues

Bunch of issues with LibreOffice 3.6–First of all, when I pinned the icon for Writer to my task bar (Windows 7 SP1), my list of previously opened files (jump list) was no longer accessible. (It was under the 3.5 version I had installed before. I did a clean install of 3.6, deleting the previous user profile before I installed, and still had the same issues.

Update: This is weird–When I pin the “Writer” icon to my taskbar in Win 7, I have no jump list available…However, when I open a document from within Windows Explorer, a second Writer icon appears on the taskbar with the full jump list, but I can’t pin that one to the taskbar.

Please be more precise - what does “Writer files refuse to register under LibreOffice 3.6” mean? Do you get a error message? BTW: Please don’t mix multiple different problems into one question.

Sorry, tohuwawohu. Regarding “Writer files refuse to register under LibreOffice 3.6”–that problem seems to have corrected itself, so it’s not an issue. However, the original issue (the pinned Writer icon no longer having a jump list of recent files, and the second icon appearing) is still there.

may I ask what is a “jump list”?
I not still on XP and assume it has to do with W7

See also → Bugzilla query – Content: “jump list” · Product: LibreOffice

I have the same problem.

Could this be fixed please. New versions shouldn’t break such elemental things. Label it a beta if it isn’t fully tested. I’m downgrading.

PS. Still big thanks for a brilliant piece of software. DS

It’s very unlikely that It will get fixed just because someone asked here to fix it. This Q&A site isn’t a bugtracker. Filing a bug is the first, most important step.

You may continue there → Bug 45600 - Jump List items in Windows 7 are not visible in Libreoffice 3.4.5

Bug 54009 - Jumplists not working explains that in 3.6x, a bug prevents us from pinning OpenDocument files (.odt, .ods, etc.) to the jumplist of the corresponding LibreOffice app. However if you e.g. have Writer pinned to your taskbar, you can pin .docx files to it.

Same problem here. Had me pzuzled till I googled it and saw others had it. What bamboozles me is that software CAN break jumplists, I’d have thought it was handled entirely by Windows. But there you go.

Same problem here. Had me pzuzled till I googled it and saw others had it. What bamboozles me is that software CAN break jumplists, I’d have thought it was handled entirely by Windows. But there you go.

oh there are so many of these kinds of problems with 3.6.x I ended up backing down to 3.5.6, works quite well

3.5.6 is a very problem version, especially when working with complex MSO documents. In some cases documents become unreadable. Migration to 3.6.x fixed all that problems for me.

with 3.6.x, you cant even get to the point where you are worried about MSO docs

50 computers use 3.6.3 and not a single complaint from users. At 3.5.6 complaints were constant

obviously alot of solitaire going on there

Bug reproduced (LibreOffice, Windows 7 and 8):

a) The pinned to taskbar button (Writer, Calc or any other) has NO jump list.

b) When pressed, a SECOND button (not pinned) appears for the running program.

c) If we right-click this second button (of the running program) we DO see here the jump list, but this button has NOT the “Pin this program to taskbar” option.

d) Same as (c), if the program (e.g. Writer) was not pinned at all. The button of the running program has NOT the “Pin this program to taskbar” option.

PS. Bug 45600 is irrelevant. 45600 is a bug of old LibreOffice 3.5.x, where the documents opened through “File|Open” LibreOffice menu or double-clicking the document from the explorer were not added to the jumplist. (But they were added if found and opened through “Windows Start|Search”.) Here, in LibreOffice 3.6.x, the bug is much more serious: the jumplist doesn’t exist at all in the first place!

Bug 54009 is also mostly irrelevant. No LibreOffice running program button at the taskbar has available the “Pin this program to taskbar” option available (when right-clicked), regardless if we’ve opened an MS doc, a LibreOffice doc, or run the program without any doc.

I had the same problem with 3.6.3 where none of my previously pinned Writer documents would show up on the jumplist. I also was not able to repin any of the documents.

I finally tried to resave my Writer document with the .odf extension, the extension it recommends when trying to save to .docx, and for some reason it worked, and without any of the formatting problems I had with the .docx format.

Hopefully that helps for those of you with Writer document pinning problems. That said, it still would be nice to be able to pin normal .odt files.