LibreOffice 4.1/4.2 linux system requirements

Currently on Ubuntu 12.10, using Mate 1.6.0 desktop. After upgrading LibreOffice from 3.6 to 4.0 I started getting system errors, but system seems stable, but stemming from incompatibility between LO 4.0 and Ubuntu 12.10

Noticed with the release of LO 4.1 that there were pages with instructions on how to install LO 4.1 in Ubuntu 12.10. In the LO 4.1 ReadMe the system requirements are as follows:

  • Linux Kernel version 2.6.18 or higher;
  • glibc2 version 2.5 or higher;
  • gtk version 2.10.4 or higher;
  • Pentium compatible PC (Pentium III or Athlon recommended);
  • 256 MB RAM (512 MB RAM recommended);
  • Up to 1.55 GB available hard disk space;
  • X Server with 1024x768 resolution (higher resolution recommended), with at least 256 colors;
  • Gnome 2.16 or higher, with the gail 1.8.6 and the at-spi 1.7 packages (required for support for assistive technology [AT] tools), or another compatible GUI (such as KDE, among others).

Checking the Kernel version was no sweat and for the GTK version I did this:
:~$ dpkg -s libgtk2.0-0|grep ‘^Version’
Version: 2.24.13-0ubuntu2

But not clear on how to check the glibc2 version or the Gnome version, with gail & apt-spi . Thanks for any and all help.


Given you’re on Ubuntu 12.10 (with Mate? interesting!), you would be better off asking this question at Ask Ubuntu - it’s more about the OS than about LibO, it seems to me.

If you are having problems with the erratic behaviour of LibO, we normally suggest renaming the config file ( .config/libreoffice/4) and restarting LibO to see whether there is any problem there.

When I install LibO on my LinuxMint 13 /Mate system and Ubuntu 12.04, I just follow the instructions further down the pages “Installation of LibreOffice on Debian/Ubuntu-based Linux systems” and use sudo dpkg -i *.deb which worked with 4.0, 4.1 and 4.2.

If you have a problem with 4.0 try installing 4.1 which is the current level. Hope this helps. Peter