LibreOffice Sum results are wrong

I have been using these documents for years: invoices receipts, repair logs, for my business. I made them a long time ago, and so far they have worked. Now all of a sudden the “sum” function is busted! I am a guitar builder/repairman, and keep close track of time worked and procedures of work performed for my clients. I fill in a repair/Build Log as I go along.

I have a table, with two columns: Work performed, and time for that procedure. At the end of the column there is the total of course. I am used to having to reestablish the sum, if the amount of rows in the column changes which is still an idiotic problem, but acceptable (would love to see a fix after 3+ years). Now (as of today) the same document I havebeen using for years, doesn’t total the rows right: I have times of 00:06, 00:04, 00:12, 00:14 = 12:00!!! The result should be 00:36 minutes. Yes the number format is right in every column, including the total.

Even stranger is that when I highlight the last row of the column and hit the sum button, I get “=sum()” What happened to B1, B2, B3, b4???

This is absolutely nuts, and before anyone chimes in with Have you tried… I have made no changes, it worked for years, so no it is not something I did wrong, I just filled in the fields as always, and it went south, so no I did nothing to cause this, and I am sick and tired of hearing: Blah Blah blah… try this, that is wrong… you have to… IT WORKED FOR YEARS THIS WAY, AND RIGHT AND WELL!!! If some update caused this, (even if new and better) I expect to be warned of changes and the consequences thereof and procedures to fix it in advance!!! More often than not the fix is related to some library, the java environment… But shit happens non the less, and how the hell is the regular user supposed to just miraculously be aware of this??? In fact they can not, and it is the people who program this stuff, and make changes to it, to make sure that it works in the first place (without breaking anything) and informing the user if it will, and giving them solutions, before it f**ks up the end users shit (and their business!!!).

Yes I am pissed: Besides my hours of physical labor, I guaranty my clients honest and documented service of my work to their precious instruments. I also need to keep accurate books for the IRS and just in case our Nanny government wants to swoop in and try to find something wrong with my way of doing business!!! I do use woods that have to be documented and have a paper trail… Accurate record keeping is a must, and not just a playground antic to be played with on the side for fun!!! No matter how honest I am and how great my business practices are, I could go to jail if my records don’t add up!!!

Hello @Zoidman!

Ok, I feel sorry for your frustration, and first of all, wish you to sort it out and resolve your problems.
And I want to make a disclaimer with regards to following: you wrote to peer-to-peer users help forum, and thus, I believe that the first thing that you did wrong is when you started to demand from others this and that. Either ask questions and try to listen to those who try to help (whatever they find appropriate to say), and try to understand their points, or don’t ask here to avoid things that upset you if you are unable to cope with that.

Next important thing is that you didn’t provide enough information about your situation. The title includes version information (, which is from October 2014, but you didn’t tell what is your OS, or what happened immediately before the event (as you mention some “update”, so I assume, something was updated? OS? Or did you perform an update?) I regard this important, because 4.x is long time unsupported, and thus is not updated by TDF. It could be that your OS maintainer made some changes, but that’s absolutely unrelated to LibreOffice creators, and they cannot be blamed for that.

The next thing: however disrupting the problem is, you just cannot expect any guarantees from software you use (be it LibreOffice, or any other), unless you received that guarantee explicitly from authors. However hard developers try to keep it reliable and robust, bugs happen, and they are something a responsible user must be prepared for. That’s one reason why LibreOffice authors keep an archive of all previous versions available for download and use: If you happen to come across a regression that is unacceptable for you, LO doesn’t enforce you to stick to any of its new and shiny current version, but you are free to revert and stick to a version of your liking.

Having said that: I just checked with v.5.3.3, and sum of 00:06, 00:04, 00:12, 00:14 correctly gives 00:36. So, possibly you might consider upgrading to this version (fixing found bugs is one reason why new versions are released).

Hope this helps, and wish you to find a good and quick satisfactory solution.

Thanks @mikekaganski I recently switched from Ubuntu to SolydK Linux with everything up to date, and I had the option during install, to either install LO from the SolydK repos, or to go for the latest and greatest. I chose the latter, and so now I have to figure out why I have this: LO Version: Build ID: 430m0(Build:2) Very strange indeed. I have been using LO for a long time, and it does not look like a version from that far back: Maybe the 4 should be a 5, under Help>About??

Also I opened the same documents this morning and it worked right all of a sudden, so I am non the wiser as to what the problem could have been.

Oh and BTW, I did not demand anything, just discouraging unhelpful replies like the useless one from (fishing for points) above, and those that point out possible operator error, as I stated I have used LO and OO for a really long time, and had I made a minor mistake, I would have checked my settings… and fixed it no time.

Ciao, with LO 4.3.7 o.s. MacOSX 10.7.5 sum result are right.


If my answer helped you, vote it with :heavy_check_mark: (here on the left)

image description

This question is about writer, as tag suggests

Well the problem just went away. I turned off the computer at night, and back on this morning, that’s all. I opened the documents again, and was going to just work around the problem, so I could get the documents to my client, and the math was all right and working again. Go Figure.

I have no idea what caused the problem, nor weather it will be back again, but I sure hope not. So the problem is resolved for now, but I cannot supply an actual answer to the problem if it happens to someone else, sorry.