LibreOffice 5.0.3 windows are all empty black - Windows 10

This is on a brand new Surface book. LibreOffice 5.0.3 was pretty much the first thing I installed (after Chrome) and it was working, but now I get black empty windows when I start Writer or click on a file. I’ve installed other programs (including Inkscape, GIMP, Dropbox, Google Drive, and AVG antivirus) and I wonder if one of them - especially AVG - might be to blame. I uninstalled LibreOffice and reinstalled with standard settings, the problem continues. I hate to mess with antivirus but it keeps insisting program temp files are potential trojan horses so I delete them. Could this be the issue? Any other ideas?

Please try resetting the user profile, sometimes solves strange issues.

I have the same issue on a new surface pro 4 but resetting the user profile didn’t help…

Please verify if modifying the using hardware acceleration or OpenGL state in Menu/Tools/LibreOffice/View has any affect?

How do I do that? There is no menu. Even the start up logo appears black. It seems to be just a visual thing because when I write something and try to close the window a black ‘safe Document?’ window pops up.

Hi, I’m the OP, I only now saw these comments. I can add that I am running LO 4.4.6 now with no issues, so the problem is specific to LO 5.0.3.

I echo the comment of eizee that it’s really not possible for me to make any alterations in LO 5.0.3 settings when it is installed, including user profiles and hardware accel/OpenGL, because the windows in the program are entirely black, including the menu areas. I am flying blind. I’m happy to answer any questions I can.

Have you tested if changing something on the screen configuration, has any effect?

I tried different display settings. I thought maybe it’s related to high dpi, a strange resolution or driver issues but nothing helped. A recent windows system update didn’t help either. LO 5.0.3 is the only program on my pc with these problems…

As I searched and finally found a simple solution in the release-notes of LO 5.0.2 / LO 5.0.3.

Just open this site, save as .reg file and open it. This will make changes to your registry and solve an issue with OpenGL.
That’s it. It worked perfectly for me.

eizee, thanks so much, that registry edit worked like a charm! I would upvote but I’m too new here. :slight_smile:

Thank you thank you THANK YOU! That fixed my problem in a jiffy!

Yes, it fixed it for me, thanks very much. I was surprised that saving the registry entries simply by saving as .reg would work… I thought I would have to do a regedit but that wasn’t necessary.

Please provide the missing steps needed to make this registry change work. For example, what exactly needs to be done when saving the ‘reg file’ ?? Is it intended to be saved as a plain text file, and what application is used to open it ?? I’ve tried following the instructions literally, saved it as ‘reg file’ in plain text format and opened in WordPad but it didn’t do ANYTHING. Clearly there are missing steps the writer has assumed readers would know but without pedantic details this is useless

It doesn’t work when its saved as ‘reg’ either. Obviously there is an a unmentioned ‘gotcha’ here. With totally black windows there isn’t any possibility of tweaking anything in LO

OK … it wasn’t clear to me that one must save the file as blah (dot) reg. When that blah (dot) reg file is double-clicked, the ‘regedit’ registry editor is invoked, thereby making the necessary changes to the registry. The apparently trivial but absolutely essential gotcha is the (dot) before the reg extension. Dunno about others, but personally I appreciate provision of ALL the minor details as they assist with ironing out the weirdnesses that are endemic to computers

I actually didn’t know more than the release notes provided, as I wrote. Maybe “.reg” would have been better, sorry for that. Did you read the release notes? I felt they were quite self explaining…
Hopefully it works meanwhile.

On the surface book with dGPU, you can right click, run with NVidia, or change your NVidia control panel settings to always run with dGPU. If you would rather not destroy your battery, once you have the program open, you can go to tools>options>view and uncheck use OpenGL, the restart the program, and it should work.

This is due to an OpenGL/OpenCL bug not fixed until end-December. Look at reply to Q64314 for more info + method of fixing (even when you cannot see the screen!).