LibreOffice x64 not installing on Windows 10 15025 x64

get as far as registering fonts on the installation wizard and then it stops, ive even left it over night and it still freezes and I have to reboot to get out of the wizard (it will not respond to cancel button)

I’ve tried as many suggestions as I can find in the forums all to no avail, even tried OO with the same result it stops at registering fonts as well.

I have full admin rights

How many fonts do you have installed?

If you have a lot, try reducing the number by un-installing un-needed fonts.

Hi, just checked installed fonts, 82 I have not added any so should be the windows norm, one question is how many fonts does LO add? two what does the installer add or do after fonts?

Just installed 15031 and LO installed without a murmur

With respect to Windows 10 and LibreOffice fonts there is an interesting note here for LibreOfficePortable from PortableApps: LibreOfficePortable Font Warning. Basically it says that Windows 10 is bugged regarding font handling.

There is a section that says this:

LibreOffice Fonts - The LibreOffice
Portable package includes the
OpenSymbol font included with the
local version but not the other font
faces. This is due to a bug on Windows
10 Anniversary that causes dynamically
loaded fonts to take 10x longer to
load. The fonts are available as a
direct download zip of fonts. You add
the fonts to LibreOffice Portable
directly by placing them in the
directory or add them to the Platform for use by
all apps by placing them in your

It MIGHT be the case that even though you are fully installing LibreOffice to the system this will be an issue. (The same sort of thing is noted for ApacheOpenOfficePortable.)