Libreoffice 5.4 font gui problem, just rectangles, macOS

Hey everybody,

I got a nagging problem with my LO on macOS. Ever since I updatet my pretty old Libreoffice installation (5.1.) on macOS Sierra, I have a problem with the font rendering on the GUI (see screenshot). I don’t really understand why. Right now I am using, but the problem is also there when I use 5.3.5. It is there with or without the german language package I need.

I tried uninstalling and reinstalling multiple times and also deleted cache and config files using AppCleaner.

Anyone has any ideas what this is about?

Thanks und cheers


I was facing the same problem, both with 5.4.5 and 6.0.1.

I soon decided it must be a font mapping problem i.e. it must have had to do with the changed system font for 10.10+ etc. so I tried several of the solutions proposed on the web, many of them without effect.

This worked:

  1. Open Applications / Font
  2. File → Restore Standard Fonts
  3. All non-system/default fonts will be removed and put into ~/Library/Fonts (Removed)
  4. Close and reopen LibreOffice; it should work now
  5. Optionally: reinstall the fonts from the removed folder and check if it still works; if not, rinse and repeat until you have identified the culprit font. In my case, I had another version of Helvetica Neue installed.


Oh my… it worked, thank you so much! Seemed this solved the bug. I restored the standard fonts and then added the the old fonts from the removed folder one by one. Strangely even though I reinstalled all removed fonts the bug is still gone. Whatever, thanks, this worked!

Thank you very much, this problem has been bugging me for a while on different Macs since a few versions of Libre Office as well as MacOS.
The solution worked perfectly on High Sierra 10.13.4 (German) and Libre Office, but I am confident it will work on other versions, too. This problem has been with me for a few versions of both LO and MacOS now.

The solution above only works if we don’t need the other fonts. I need my other fonts. Any other solutions?

The solution above should work in all cases. If you read carefully, it tells to reinstall the removed fonts one by one, checking the results at each step; you may either find (a single) problematic font(s), or even be able to successfully reinstall all fonts (as @janoherder mentioned), which would mean that not fonts, but their registration info was somehow broken, and now correctly restored.

And this is not an answer; your comment should go the comments section.