LibreOffice 5 for mac will only print landscape. Please help

LibreOffice 5 for mac will only print landscape. Please help.

I also have this issue. Changing the page orientation under Format > Page … does not change the orientation of the printed page. In the Mac print dialogue, the preview under the Libre office settings appear normal, (portrait) whereas the preview next to it on the Mac print dialogue shows the text printing in landscape orientation. When printing it is the landscape orientation that is printed.
Please help.

Just noticed that the answer below to a similar question (Stuck in 'Landscape' but I chose 'Portrait'. HELP) provides a useable work-around.
Basically, File > Export as PDF generates a pdf with the correct orientation.
With gratitude to fulldecent…

I am having the same issue LO on Mac 10.10 and 10.11. Documentation is at
fulldecent gravatar imagefulldecent (Sep 18 '15)

Same problem here. PDF workaround is a great idea, thanks!

LO and LO on either macOS 10.12.6 (Sierra) & 10.10 (Yosemite) have the same ‘landscape issue’ with Letter Size (8.5"x11") while printing in portrait format.

My work-around is just to convert letter size to user-format (8.5" x 10.99") or (8.49"x11"), which don’t have noticeable effect on the margins.

Exporting to PDF before printing works but annoying if you are in a hurry.

(OSX 10.10.5)

Here is a simple workaround I discovered for this issue. It seems to work most of the time but not always.

In the print dialog, click the “More” tab (next to “LibreOffice Writer” tab), change Include option from “All pages” to “Back sides / left pages”. This reloads the print dialog with the correct page orientation and showing the back page (if you have only 1 page the back page will be blank). You may then change back to “All pages” and the correct page orientation remains.


This workaround is working on my config : macos 10.11.6 , with LO .
This bug is weird .

This worked after I chose more>“right pages” “checked brochure” “apply” and then chose more> “all pages”, “uncheck brochure” “apply”. Basically, changing the “more” options can trigger a return to “portrait”
…seems like a long time for such a prominent bug.

Thank you mweinmeister! Your steps worked for me in LO on MacOS 10.12.2, leaving out the two steps “apply” which seem no longer to exist.

Thank you!!! This worked for me. I was racking my brain trying to figure out why I couldn’t get it to switch to portrait.

LO folks must have tested it on A3 paper because it does not rotate it to landscape. So, until they fix it, you can use A4 Paper Format and set your margins to Left .79, Right .42, Top .79, and Bottom to 1.48. If you want something than the traditional size margins, you might have to do the math yourself.

MacOS 10.12.1 fixes this problem and the select problem.

This fixed it for me for now. I created a template with these settings, then set it as my default template. My documents now print out in portrait mode. For reference, I’m using Mac OSX 10.13.2 and Libre Office and nothing else seemed to fix it.

This problem has returned. LO, OS X 10.12.6

the work-around, to Export as PDF before printing, does work. But it is awkward. Maybe I need to go to MS Office??

Problem still exhibited in MacOS 10.12.6

Wow! Just fucking wow! This is still an issue. LO OS X 10.13.3 What a joke!

May I suggest you choose your words more thoroughly?
Why did you judge your post above to be an answer?
Why did you enter this very old thread? There is nobody in charge of updating old threads if more recent ones contain better info.
Did you finally try V5.4.4? It was (inofficially) announced to fix the issue. Lacking access to a Mac I cannot test.

May I suggest that if you don’t have a Mac and can’t intelligently comment on the problem the you STFU?
“Inofficially” is not a word.
V5.5.4 does not fix the problem.

Well, I’m not a native speaker of English, and sometimes I may type the wrong letter, but I recognize a rude fool even if he writes in English and uses those awesome acronyms.
Hope you find a better forum to boost it with your very first post.
BTW: There is no LibO version 5.5.y.