LibreOffice_6.1.6_Win_x86 installs fine, LibreOffice_6.2.8_Win_x64 won't run

brand new windows 10 PC latest v1911. x86 is 32bit? I ran that before on windows 7 so this is maybe a 64 bit thing?
uninstalled and reinstalled x64 again, same. install completes ok but application won’t start, gets exception.
tried x86, installs and runs ok. haven’t tried 6.2.8 x86.

faulting module contains “amd64” but my pc is Intel. significant?

Faulting application name: soffice.bin, version:, time stamp: 0x5d9f7ad8
Faulting module name: ig9icd64.dll, version:, time stamp: 0x5cc8f610
Exception code: 0xc0000409
Fault offset: 0x00000000009d7185
Faulting application path: C:\Program Files\LibreOffice\program\soffice.bin
Faulting module path: C:\WINDOWS\System32\DriverStore\FileRepository\iigd_dch.inf_amd64_0ae3017dc8a033a4\ig9icd64.dll

There is no Windows version 1911 - latest Microsoft Update is 1909 (Build: 18363.476) - and please clarify your WIndows Versions bitnesss at Windows Start -> Settings -> System - > About. In section Device specifications there is an item called System type which tells you whether your operating system 32-bit or 64-bit.

But according to your error code 0xc0000409 this issue seems not to be related to LibreOffice but a damage of some system files of your Windows system. Check on the web for 0xc0000409 (e.g

Regarding “amd64”: For historical reasons it is common is to use the term “amd64” (also in use: x86-64) to state that it is “64-bit”, regardless of the manufacturer of the processor (Intel or AMD).

this ig9icd64.dll is part of the openGL driver for intel graphics accelerator. there is also a ig9icd32.dll. I have Intel UHD Graphics Driver 24/7/19. all other programs work ok and presumably other LibreOffice users would have the same level of windows and integrated intel graphics and yet don’t have my problem … ???
you are right it is 1909 (released November).

If the problem is related to OpenGL - try to disable OpenGL in Tools -> Options -> LibreOffice -> View -> Category: Graphics Output -> Option: [ ] Use OpenGL for all rendering and check whether that fixes your problem