LibreOffice won't open/not responding upon launch win8

As title says, LO won’t open and hangs up.
I tried different solutions and most of them are already outdated or not for my operating system.

Same problem here after installation today 11-Jun-19 - no solution found anywhere…
Anybody from the IT wizard pool?

Thank you for this useful solution of @emeow64’s question!

It has to do with the repositories. I think they are different for LO 5 and 6 and the one for 6 is not added to whatever is added to Chromebooks. Having tried every solution I can find, my conclusion is we are stuck with LO5 until the developers do whatever it is they need to do. I even tried adding the repository at one point and still could not open LO. It is frustrating because it looks as if all goes well till you try to use LO. I get tempted to try after every update. (I enabled Canary.) Having searched the Internet high and low for a solution and trawled through what people say here, I think we are wasting our time until the Chrome developers do whatever it is they need to do. It has something to do with them only adding what they think is stable. Of course, we could all create a Linux OS alongside the Chrome OS, but that voids guarantees and is a risk. I did it for a bit but did not find the solution that satisfactory although I got LO 6 that way. It was not that stable.

@JackyAnn: possibly you meant to comment some different topic? Since this is about Win8 (according to the original question; of course, the “answer” by @accuro100 has no information at all).