LibreOffice 6.2 crashes crashes on Mac OS Catalina after a while

Hi there,
after switching to MacOS X Catalina (10.15) LibreOffice crashed after a while. I can open, edit and even save documents when I’m quick enough, because after around 30 seconds LibreOffice crashes.
Sometimes I get the message Due to an unexpected error, LibreOffice crashed. and sometimes the crash report dialog from Mac OS X pops up.

I have tried the latest stable version 6.2.8002 (6.2.8002) from Download LibreOffice | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft and I tried to install the newest version available at homebrew (6.3.2) but the Symptoms are the same.

Here are the first lines of my crash report:

Process:               soffice [15529]
Path:                  /Applications/
Identifier:            soffice
Version:               6.2.8002 (6.2.8002)
Code Type:             X86-64 (Native)
Parent Process:        ??? [1]
Responsible:           soffice [15529]
User ID:               501

Date/Time:             2019-10-20 13:53:22.259 +0200
OS Version:            Mac OS X 10.15 (19A602)
Report Version:        12
Bridge OS Version:     3.0 (14Y906)
Anonymous UUID:        42039164-2841-55CE-B22F-1122999A04AA

Sleep/Wake UUID:       C057D13F-E441-41D0-B4D0-71B9ECA82E11

Time Awake Since Boot: 22000 seconds
Time Since Wake:       1000 seconds

System Integrity Protection: disabled

Crashed Thread:        4  UpdateCheckThread

Exception Type:        EXC_BAD_ACCESS (SIGABRT)
Exception Codes:       KERN_INVALID_ADDRESS at 0x0000000000000010
Exception Note:        EXC_CORPSE_NOTIFY

To me it looks like the UpdateCheckThread is causing the crash which makes sense, since LibreOffice works fine for a while and it crashes after a while without doing any specific action.
I have a working internet connection.

Any idea why this is or how I can solve it?

Kind regards

tdf#127619 is about the same problem - but it tells about pre-Catalina…

Thanks Mike, that’s exactly my issue!
I started LibreOffice again, went quickly to the settings and disabled AutoUpdate. Now it works without issues!
However if I trigger the “check for update” function LO crashes immediately.
But at least I can use LO now and I can live with manually checking for updates and install them from the website. Maybe I can re-enable the update check if the issue is solved in a newer version.

That bug needs a crucial piece of information, which could help fixing it. It is bibisection, a process of finding the firch code change that resulted in the problem.

To bibisect, one needs to be able to reproduce the problem, and have some energy to repeatedly (around 12 times) launch the program to nail down to the problematic commit. You have an environment where you can reproduce the crash. If you could spend some time bibisecting, and post the results to that bug, that would be really important contribution!

Hi Mike, I would like to assist by investigating on this and/or trying different versions and follow the Bibisect guide.
However I’m sceptic that this might help in this case:

  • I was running an older version (I think it was 6.2.4) when the issue happened for me right after upgrading to Catalina (it did work before!) and it also happens with 6.2.8 and 6.3.2 which are the current versions. Looking at Bug #127619 this issue is related to some external library (nss3/nssutil3) or other circumstances. Since from my understanding there is no version that has introduced this issue and the only workaround is to disable the update check, it is unlikely that an intermediate version would not have the issue.
  • I’m not using LibreOffice Vanilla for Mac (in the Mac App Store). Instead I downloaded the release from the website and now switched to a homebrew cask (6.3.2).

If I did not understand this correctly please let me know.

The bug report claims that the first failing version of LibreOffice was 6.1 - so first step would be confirming that 6.0 doesn’t fail, and 6.1 fails. Then, if that’s true, then you’d need to download the 6.1 bibisect repo, and follow the procedure to find the problem. If 6.0 fails, then bug report needs updating, and earlier versions need checking, until either a version that doesn’t fail is found, or it’s confirmed that it was failing forever…

Turning off the automatic updates worked for me.

I am on Mac OS High Sierra, and I had the same issue. I upgraded from 6.2.5 to 6.2.8 and it seemed to work ok. Sometime in the last week I installed the new security update from Apple, and after that I noticed that LibreOffice kept crashing. I just spent the past day trying all sorts of fixes, resetting my user profile, reinstalling Java, reverting to 6.2.5 or earlier versions from my Time Machine backup, and even reinstalling XServer. After everything I tried, LibreOffice would crash after a minute or so. I finally stumbled upon this thread and disabled the update check. Now it’s been over 10 minutes and LO is still running! So excited that I created a user account on here to post a comment on this thread!

@hring Thank you for the feedback. It was also my observation that the issue started after a Mac OS system upgrade, not an update for LibreOffice.

@Mike2 I have downloaded LibreOffice 6.0.1 from Index of /libreoffice/old/ and I confirm that the issue does not affect this version. I can manually check for updates without an issue which caused the latest versions to crash. However, when I try to open the preferences panel in LO it crashes immediately. But that’s another issue which is unrelated and it does not occur on the latest version.
Would downloading the different LO versions from Index of /libreoffice/old be an option to nail down what the first version was that has the update issue?
I took a look at the Bibisect guide but I’m confused that there seems to be no repository for versions 6.0 and newer (see

You need only to download v.6.1.0 - to check that the problem indeed started between these two major versions. If it did, then you need to use bibisect repo for 6.1 - which is mentioned on the bibisect page that I referred above. Thank you!

I have downloaded version and LO crashes as soon as I hit the ‘Check now’ button in the Online Update section of the preferences. I’m currently doing a “git clone bibisect-/ - Gitiles…” and see how that works.

I have cloned the Bibisect repo bibisect-mac64-6.1 and did a git checkout oldest and made sure that the issue did not happen on this version (
From my understanding of the Bibisect guide the next step would be to do a git bisect start latest oldest but this gives me the following error:

error: update_ref für Referenz 'refs/bisect/bad' fehlgeschlagen: cannot update ref 'refs/bisect/bad': trying to write ref 'refs/bisect/bad' with nonexistent object a0342aebfe7f0000a088ba6aff7f000000000000

I removed and downloaded the repo again to make sure it is complete, this didn’t help.
I typed the command just as it is, do I need to replace latest and oldest with the version hashes of the repo from a git log or something else?
I’m sorry for being this stupid, but I’ve never done a bibisect before and have no idea what the error is caused by or how I can address that.

You did everything right, and the error message looks really strange.
Try git bisect start master oldest.

But first - please try git checkout master and try there, to make sure that it does crash there.

Hi Mike, thank you. I did a git checkout master and successfully started but it crashes as soon as I hit the Check now button. So this release is affected.

I then did a git bisect start master oldest and this worked and I could start after the checkout completed where the update check works.
I then did a git bisect good which took me to the next version to check and I did it again for 12 steps in total and ended up with the following result:

I had to use pastebin to not exceed the character limit.

I think we nailed it down to the breaking commit. Did we?

GREAT! That is - which is “Upgrade update check and extension URLs to https”. This is definitely the correct one!

Please write that to the bug report - that possibly could greatly simplify the fix. Unfortunately I myself cannot fix that, since I have no macOS.

Thank you very much for your work!

Thanks again for your effort and support on this Mike!
I’ve updated the bug report:

FWIW I had this problem on Mojave too (version 10.14.6 (18G1012)) and disabling the auto-update mechanism fixed it, as described on the bug report.