Libreoffice 6.4 base problem with date dropdown control Linux - Solved

Hi I am using libreoffice 6.4.1 Base in endeavour OS linux (arch). I am having a problem with date control in a form where I set it to dropdown. When I enter the field it takes a while to respond and when I click the down arrow it again takes a while to responds after the second click. However I can not click in any other form control after I click on the dropdown and cursor is gone. If I close the form and reopen I can then enter other fields.

I have tried on a laptop with EndeavourOS and same thing happens. Tried Openoffice on the laptop and that is fine.

Has anyone got this problem or can you help out. Am I missing a graphic plugin or something. I have to use windows libreoffice which is fine.


Working in another arch xfce laptop ok, fresh install of libreoffice and java. I was wondering if problem maybe java related? The desktop which has kde and the problem java status is

archlinux-java status
Available Java environments:
java-13-openjdk (default)

and here is what I have installed:
pacman -Qs java

local/beanshell 2.0b6-2
Small, free, embeddable, source level Java interpreter with object based scripting language features written in Java
local/ca-certificates-utils 20181109-3
Common CA certificates (utilities)
local/fastjar 0.98-5
Sun java jar compatible archiver
local/gjs 2:1.58.5-1
Javascript Bindings for GNOME
local/hsqldb2-java 2.5.0-1
HSQLDB Java libraries, Version 2
local/java-environment-common 3-2
Common files for Java Development Kits
local/java-runtime-common 3-2
Common files for Java Runtime Environments
local/jdk-openjdk 13.0.2.u8-1
OpenJDK Java 13 development kit

I am going to mark this as solved since the problem is now fixed, I believe. I am not sure just how but I have changed couple of things and ever since libreoffice is looking and acting a lot better. One was to install ttf-ms-fonts from AUR and the other and possibly the main one is that I configured default UI renderer as VCL:gtk3_kde5.

image description