LibreOffice 7.3.5 (x64) - 'Options' window very slow to open on Windows 10

Hi all,
Any LibreOffice application (Writer, Calc, etc.) opens in about 4-5 seconds on my system. However, if I go to Tools > Options, I get a spinning blue circle and (Not responding) for about 60 seconds before the Options window opens. So it’s not a complete crash but something is definitely going wrong.

I saw suggestions on other questions here that in Options > LibreOffice > View disabling ‘Use hardware acceleration’, ‘Use anti-aliasing’, and ‘Use Skia for all rendering’ may help. I tried disabling one at a time and then all of those to no avail. I also completely removed the installation and re-installed it fresh which didn’t help. There are no errors listed in Windows Event Viewer for LibreOffice.

This problem is reproducible as it happens every single time. Admittedly, one doesn’t open Options very often so waiting 60 seconds isn’t a big issue but whatever is causing this is likely to be affecting more than just the Options window. Specifically, I’m worried about potential data loss.

Does anyone have an idea what’s going wrong or maybe point me to a LibreOffice log of some sort where I can look for errors?

Thank you in advance for any help.

Is it a clean install? (Have you deleted the User profile manually before you had install the newer version?)

Nore: the 7.3.5 is the Fresh version. Use the Still version for the daily works, and please report the bug on the bugreport site.

1 Like

This specific delay duration (or its multiples) on Windows is always suspicious for some access attempt of an unavailable network resource (it could be a path on unavailable server, or a turned off shared network printer).

Note that re-installing has nothing to do with saves settings, because they are stored in user profile, as @Zizi64 mentioned; so please check if following @Zizi64’s advise about clearing the profile helps, or check if there are maybe paths (Options|LibreOffice|‘Paths’) that point to a problematic location. Or also check if you maybe use a template that has such a problematic printer, or even maybe such a printer is set as default on your system.

Another potential source of the problem could be the PGP signing feature: given that the initial opened Options page is User Data, and it only has one group of controls that may have unwanted effects - the one related to PGP signing (that involves separate executables, and maybe network access), I thought you might want to check if you have some system setup related to that (Kleopatra misconfigured?)

Also: is your system a standalone (home?) box, or is it a member of some domain? Asking just to rule out a possibility of some sort of delay-loaded Active Directory group policies configured on a domain level (not that I really know if that sort of problem is even possible, just a blind guess).

1 Like

TL;DR It was a powered off printer. The Windows default printer attached via Wi-Fi, in fact. I powered it on and the Options panel now opens in about 4-5 seconds.

Steps I tried:
I deleted the user profile and re-installed once again. Didn’t help. I also checked Paths and they didn’t seem to be pointing to anything unavailable (NAS drive, for example). The system is also stand-alone and not part of a domain. I checked my Kleopatra settings and nothing seemed to be out of order. I wasn’t sure if Active Directory was even in effect and evidently it’s not because it’s not listed in Administrative Tools.

Finally, as the last step, (of course) I looked at the printer (another part of the house) and noticed its ‘power savings’ had turned it off so I turned it on. Checked the Options window opening again and Voila! Problem solved. Apparently, the Options panel was for some reason trying to reach an unavailable printer, thus the long delay.

Thank you for your help with this matter!

1 Like