LibreOffice slow and consistently "not responding" on Windows 11, plus "Document in Use" Notice

I’ve been experiencing an issue with a particular .docx file that has been causing the LibreWriter program version to suffer from severe latency and with that an eventual “not responding” notice, the file is 899 KB. While I have been experiencing overall slow speeds when using the program no other file of mine has consistently not responded and caused me to force close.
Furthermore no matter the file the LibreOffice program has been giving me the following notice when opening files: “Document in Use… This file has been locked by another user…You can open it in read only… You can open a copy on your local system”. Which I then remedy by turning off my ransomware shield settings.
This has all started to occur since my most recent update to version Any guidance to a solution to any or all these issues would be appreciated.

Please upload that file here.

See attached. Thanks.

Problem_File.docx (899.0 KB)

Just a test:

The attached file works fine for me on Win 10 x64/LibreOffice 7.5.7 x64 version.

There are non-optimized images inside. Crop the irrelevant parts, optimize the dpi and the physical size, reduce the color depth of the images before you embed them into a document use the lossless compression type .png file type for the simple (lineart like) computer graphics.
(Your large image overflows the margins, and the page size.)

Then: Does your ransomware shield knows of your update? Are perhaps all your files checked against internet source for ransom files? I would start there investigating…

I have been able to remedy the issue by blocking the libreoffice then from the prompt my antivirus service gives me I select always allow. I am using Avast and tried allowing the LibreOffice application in the ransomware shield settings however that didn’t seem to work. All in all everything seems to be in order, as for the latency issues I found that the Skia setting was not enabled so I toggled that and it significantly sped up the program.

I appreciate your input.

You need to add soffice.bin to the allowed list, not the exe files.

1 Like