Libreoffice 7 Writer: Read-Only Content Dialog


I’m trying to edit a document I created in Writer (odt file)

But I cant seem to edit it, when I attempt to add text to a paragraph I get the following dialog:

Read-Only Content
Write-protected content cannot be changed.
No modifications will be accepted.

Looking around I don’t see any of the options most people use to disable this. (There is no option > writer> Formatting aids, as an example)

How do I disable this dialog and make my document writable ?


Edit: I think it should be mentioned this is a ‘new’ xml form, and that the document has some textbox forms on it (to adjust some values like telephone numbers or names) these can be edited with default values (wierd) but nothing else can.

I also think this is a bug though, as creating a new document and simply pasting the contents back into it works and the saved document is now always edit-able.

So a work around for anyone who encounter this problem is probably much easier to select all, and paste into a new doc.

included pic (thanks for the comment @anon73440385)!

Your text may be part of a write protected section - check to Right click within the text -> Edit Section... and disable option [ ] Protect.

I wasn’t able to post a pic here, but I dont see Right click within the text → Edit Section…
Its just the standard context menu popup with options to choose: Cut(grayed); Copy; Paste(grayed); Paste Special; Character; Paragraph; Bullets and Numbering
I also tried on the main top menu Format > Sections, but this is grayed out.

hmm - is your text part of a table and option Table -> Unprotect cells is available?

btw: Uploading images works while you [edit]( your question - use the image symbol:

image description

Thanks for the reply, the text is not located in a table structure.

(I was also referencing the ability to add images in the comment section, such as your comment above, I’m guessing that’s a privileged function, still helpful though)

If the document does not contain sensitive or private data, attach it to your question for forensics analysis.

Hi. Probably anti-virus or OS update. See my answer on question 267726 Cheers, Al

Disabling Windows Defender had no effect.