LibreOffice Base connect to Google Sql Cloud


I tried to connect to a Google Cloud Sql DB from LibreOffice Base. The process seems to be quite similar as is described here. The connection itself is established, no problems with that. Also using Base tool I can create a table - which is saved successfully to Google Cloud Sql. Now I’m trying to double click this newly created table and insert some data. At this point I’m getting the following error:

The data content could not be loaded.

SQL Status: 0A100

CONCUR_UPDATABLE is not implemented yet.

The SQL command leading to this error is:

SELECT * FROM `test`.`info`     

Well, the error message seems to be quite self descriptive. But I want to know if there some workaround related to this issue. Maybe I can guide LibreOffice Base to not use this CONCUR_UPDATABLE option?

OP: @chirgeo

Maybe the issue is related with primary key. LibreOffice help:

No, my table actually contains an ID which is set as primary key, I created new one to double check it. Still the same error described above. Thx.