LibreOffice Base SSL connection to PostgreSQL (Linux)

Can’t perform an SSL connection with LibreOffice Base 3.6.2 to PostgreSQL 9.1 using SDBC driver on Linux.

Using the following connection string:

dbname=******** host=******** port=5542 user=******** password=******** sslmode=requiere

It fails with: “invalid connection option sslmode”, and obviously if I remove the parameter if fails too because non-SSL connections aren’t allowed in my PostgreSQL instance.

It’s funny because sslmode parameter works on LibreOffice 4.0 over WindowsXP.
What’s happening?

Hi @fontanon,

My first thought here is that there might be a bug in 3.6.2 that’s fixed in 4.0. Is it possible for you to install the latest release on your GNU/Linux system and see if that fixes the issue you’re experiencing?

If that doesn’t fix the issue, perhaps there is some kind of syntax difference between the Windows and GNU/Linux builds (although I would hope that these things are standardized as much as possible!)

In any case, please try out the 4.0 build and let us know how that works!


@fontanon – still experiencing a problem with 4.0?

you mispelled the value, it should be “sslmode=require” not “requiere”