LibreOffice Base: Tooltips fail to show for Form controls that have a Flat border

Dear LibreOffice Users,
In Design Mode all the tooltips are shown when i move the mouse over the Form controls, including all controls with a Flat border.
However these same tooltips are not shown in controls with a Flat border when the Form is in “Live Mode”.
Only when i place the mouse cursor exactly on the 1-pixel border of the control, does the tooltip show up.
Can anyone reproduce this behaviour, or knows how to fix it?
Thanks in advance, lib

2017-04-01 UPDATE

After deinstalling and reinstalling the whole of LibreOffice using the Ubuntu Software Center, the above stated problem no longer occurs.
My tooltips now show up when the mouse is on the inside of a flat control. And also in controls whose Border property = “3D look” or “Without frame”, do my tooltips show up. The new tooltip behaviour is now exactly the same as what @Ratslinger and @EasyTrieve have described:

  1. Some controls have yellow tooltips with barely readable text, e.g. Listboxes and Multiline Textboxes.

  2. Placing the mouse cursor precisely on the border of these controls having yellow tooltips, triggers a black tooltip.

  3. Both the yellow and the black tooltips display the text in one long line, instead of making a compact text block like before.

I’m guessing by “Tool Tip” you are refering to “Help Text”?

Hello @EasyTrieve, thank you for looking into this.
i was indeed refering to the “Help Text” for controls, that are supposed to be triggered when the user moves the mouse cursor over the control and hold it there for a few seconds. I saw that this same feature is sometimes called “Tooltip” or “Balloon Text” or even “Bubble Text”.

On (Linux Debian) it’s flaky too.

Took these two screen shots showing how depending on where you hover over the control you get a different color Help Text. The first one is not very readable, but it’s there.

image description

image description

Help Send Feedback where to check for bug reports, or submit one:

image description

Thank you @EasyTrieve, so it appears that LO creates 2 different kinds of Tooltips: one in Black for the frame part of the control, and one in Yellow for the editable text part of the control. In my case the yellow variety never shows up.

Have tried this using Linux Mint 18 & LO v5.3.1.2 and cannot find any problem as you described. Have tried this with Text box, formatted field, pattern field, group box, numeric field and time field. Have used flat, 3 D and no frames. All produce the same results - Help text is always displayed at, near or within the control.

Have tried this in Edit mode, Live mode from edit and Live mode and no problems detected.


With further information from @librebel I installed LO v5.1.6.2 on Ubuntu 16.04. The test was done on both Unity & Xfce.

Using the same test file from above (eight different controls), all displayed the Help context without a problem. Switching to Live mode, two of the controls only displayed a blank box with a yellowish background where the Help context was in Edit mode. Back in Edit mode, the difference was in the General properties of the controls - each had Text type set to Multi-line. Setting this to Single-line resolved the problem. Borders seems to have nothing to do with the problem.

Loaded LO v5.3.1.2 and the same problem occurred.

Back to Mint 18 system for further verification. Only difference now was in JRE. On Mint18 was using Open-JDK so switched to Oracle JRE 102 so both tests were equal. No change from original results on Mint 18. All worked as it should.

So, used same LO & same JRE on both systems with different results. As I really don’t care for Ubuntu (just keep it for testing) I’ll leave the next part up to you. If you find the fix, please report it back for others (and myself). I believe the final answer lies in color choices for the system or in the Theme used and here is why.

Using Ubuntu, on my system, the single line selection produced help text in white characters on a black background; the multi-line selection had a yellowish background with SEEMINGLY no text.

Using Mint 18, on my system, the single line selection produced help text in black characters on a white background; the multi-line selection had a yellowish background with black text characters.

Not positive, but it seems it may just be the color of the text in the multi-line help on Ubuntu is not showing because it is the same color as the background.

Thanks for trying … i’m using Ubuntu 16.04 and LO version

Will try later to dl and try on Ubuntu 16.04. Are you using Unity?

yes unity 7.4.0
i also fiddled around with some SAL_USE_VCLPLUGIN settings if that matters… the above phenomenon occurs at least with SAL_USE_VCLPLUGIN=gtk3

After trying several more settings following the answer by @Ratslinger, i made the following observations:

  1. For all my tooltips goes: if it is shown at all, then it is always shown in the same way, namely white text on a black (or very dark grey) background.
    i do not get the yellow tooltip variant at all, for any control in my Forms.
  2. My tooltips fail to show up in Live Mode, not only when the Border property of the control is set to “Flat”, but also when it is set to “3D look”.

However when the Border property is set to “Without frame”, then all of my tooltips DO show up in Live Mode.
3) Setting the Text-type property to either “Single-Line” or “Multi-line” has no effect in my LO, since the above problem still occurs under both settings. ( also with the third option “Multi-line with formatting” it still occurs so long as the Border=Flat or 3D look).
4) Setting Tools:Options:LibreOffice:General:Help:Extended Tips to either ON or OFF has no effect on the above problem.

@librebel Your comments are interesting since you are getting different results even though it appears we are operating under the same conditions. A question for you - Is your version of LO a distro version or one directly from LO?

it’s a distro version, Build ID: 1:5.1.6~rc2-0ubuntu1~xenial1
further info in the About box says:
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default;
Locale: nl-NL (en_US.UTF-8); Calc: group

I have seen 4 - 5 times in the past year (once on Ubuntu) where the distro version had a problem not present in the LO version. This may be the situation in your case. This is the only difference in our testing. You would need to go to Ubuntu for a resolution.

One more test today (really don’t care for Ubuntu Unity). Removed the LO version and installed the distro version. Had no problem with any of the previous tests I had set up. Even created a new form with basically the same tests. Regardless of settings the Help text always displayed with Black text on a yellowish background. Keep in mind, my Ubuntu 16.04 is pretty much without change since installation. Played around with settings for abt. an hour without success.