Libreoffice Basic File.dispose throws exception on a OneDrive Folder

Solved, Just in case anyone else runs into this…
Specify 0 for MacroExecutionMode gets around/solves the issue.

Was working fine until tonight.
Have files stored in a synced OneDrive Folder.
Always keep on this device is checked.

Using StarDesktop.loadComponentFromURL works fine.
When I call FileObject.dispose it throws an exception and closes the file fine.
If I move into a non OneDrive folder, it works fine.
Like I said worked fine for several weeks until tonight…
No lock files in local directory or online in OneDrive…

This is exception error: ScriptProtocolHandler::createScriptProvider: invalid attempt to assign an empty interface of type!

Version: (X86_64) / LibreOffice Community
Build ID: 9f56dff12ba03b9acd7730a5a481eea045e468f3
CPU threads: 4; OS: Windows 10.0 Build 19045; UI render: Skia/Raster; VCL: win
Locale: en-US (en_US); UI: en-US
Calc: CL

Instead of modifying the question like this, please add a solution with the answer text, and mark it as the solution - this way, anyone looking for a similar question would immediately see already in the search result list, that this question is answered, and has a satisfactory solution - unlike the current situation, when your question will be shown as having zero answers, let alone solutions.


Specify 0 for MacroExecutionMode gets around/solves the issue.

1 Like