LibreOffice Calc 0 > 0 returns true?

trying to create a formula where it calcs if two things are greater then 0 however if any of them are 0 it returns true. the fields are whole numbers filter only and the formula works perfectly if the fields are empty but not if they are ‘0’.

my formula is “=IF( AND(EC2>0,N36>0), 3, 0)”
EC2 is ‘0’ whole number filter.
N36 is ‘0’ whole number filter.
it is posting ‘3’ as if true.

if EC2 and N36 is empty instead of ‘0’ it posts ‘0’ as wanted.

LibreOffice version, Windows 10 64bit.
Link to example file
(it is cell R36 with reference to EC2 which is not working. if EC2 is empty it works, if it is a zero it doesn’t

Also side question, how do i add more then one tag? doesn’t accept ‘,’ or ’ ’ as delimiters :frowning:

Mention your LO version, OS, and also please provide an example file with the issue (post a link to a share where you put the file).

="0">0 should return TRUE
=0>="0" should return FALSE
Check the type of your operands.
=0>0 will surely return FALSE if entered exactly this way. If one or both of the zeros here are in fact references you expect a zero returned for, the result is a question of the types returned.
="0">123 will also return TRUE.

Edit1 regarding the comments below:
I don’t think there’s a way to get a control in Calc to deliver a different type to its linked cell than the type it’s made for. The only form control I know that delivers a number is ‘Numeric Field’ from ‘More Controls’.
Since the linked cell should be a helper anyway (and actually is in the given example) the solution is trivial: Simply use an additional helper. In the given case columns DS and EC contain the linked helpers. Columns DT and ED are empty. Put =0+DS2 into DT2 and =0+EC2 into ED2, fill the formulae down as far as needed, and refer to DT or ED where you intended to refer to DS and EC respectively. The arithmetic expression with its leading number will cause an automatic conversion to number for the second operand. To do it more cleanly I would prefer to use the VALUE() function: =VALUE(DS2) e.g.

sorry I only put the quotes for readability, they are both just 0

So take a look at the whole EC column. It’s formatted as Text. And all the “numbers” there are indeed text. If you select, e.g., EC4 that contains “1”, the “Average” is still empty, and Sum is 0 in the status bar.

So the answer by @Lupp applies here. He referred to text, not to attributes like quotes.

thanks, figured out how to change them to be set as ‘numbers’ instead of text however my checkbox turns it back into text, is there a code or something I can add to the ‘Reference value’ in the checkbox so it changes the cell as a number instead of as a text?

I don’t know if you can make checkboxes set numbers instead of text. But you could use a formula like =IF(VALUE(EC2)>0; 3; 0).