LibreOffice Calc 7.0 very slow

Good afternoon,

We are experiencing issues with a complex spreadsheet in Libre Office Calc 7.0 running on a Windows 10 machine. The file contains macros and the performance issues are the same with both macros enabled or disabled. It’s slow opening the file and then zooming in/out. We don’t have these issues when opening the file in a Linux machine (LibreOffice 6.4 on CentOS 7).

I would like to know if someone else has experienced similar issues in Windows, if this is a well known behaviour, whether there are some settings in LibreOffice that we could tune to improve the situation, etc. I have been reading about similar performance issues in earlier versions of LibreOffice and some tips on memory configuration. I haven’t been successful finding similar settings in LibreOffice 6.4 at least.

Thanks very much in advance,
Maria

Please try Help -> Restart in Safe Mode, open your file again and check whether the problem is still there. If not, you propably have a corrupt LibreOffice user profile, which requires to be reset to factory settings.

Thanks a lot for the advice. I have restarted in Safe Mode and the situation has improved a bit. At least the document doesn’t hang like before. It’s still quite slow. I have reset factory settings, but still it’s slow. Is there anything else I could try? I have also tried to disable HW acceleration, but it’s also slow. I have followed this recipe: https://wiki.documentfoundation.org/F

Thanks! Maria

Good afternoon,

I would just like to add that we have now simplified a lot the spreadsheet, removing any extra complexity and just leaving a high number of columns with some numbers on them (556). This is still very slow when we open it in a Windows machine and for zooming in/out. Any other tips to try to improve the situation? We are using machines of 8GB of RAM.

Cheers,
Maria

  • What is the overall size of your document?
  • Which format do you use (.ods or any other format)?
  • Which option exactly do you mean by “I have also tried to disable HW acceleration”. Did you try to toggle option [x] Use Skia for all rendering?

Format is ods, the size of the document is 200KB for the first example and 400 KB for the document with 556 columns. Although the problem was originally reported by a coleague who uses 7.0, I am using LibreOffice 6.4 and I am experiencing the same issues. Both of us are using Windows 10.

For the HW acceleration, I restarted on safe mode and then selected configure → Disable HW acceleration (OpenGL, OpenCL). I can’t find the suggested option.

Thanks a lot!

If you don’t find the [x] Use Skia for all rendering option your are not using LibreOffice 7.0.0. This option is new (replaces the OpenGL rendering and not available in versions <7.0.0).


The size of your document is ridiculously small, if the size unit is really **kB** - I suppose the problem is within your specific document.

For LibreOffice 7 on Windows 10 try:

Tools → Options → LibreOffice → View → Graphics Output

and disable “Use anti-aliasing”. Leave everything else as installed/default.

that´s it.

Long Live LibreOffice.

Would you so kind to explain what is anti-aliasing ?

Already tried (see above), does not solve the problem for any of the of me tested versions (6, 7.0 7.1).

I have to agree: LO, now version 7.0.3.1 has become extremely slow on Windows; I cannot observe the same on Linux, however.
That effect is variable but does not seem to depend on specific documents; the same documents may be opened fast or veeeery slow (we are talking minutes here). The same is true for dialogs: they may appear immediately, but it sometimes may last really long until they appear.
These observations are made on my work computer, where the IT-unit is installing and managing the programs, så my possibility to see and manage the environment is limited.
The change came from version 6 to version 7.
I use LO even for lessons at our university, but it is starting to get difficult to even be able to show the presentation in time for the lesson to start…

Some other observations:

  • resetting the profile does not help
  • neither does activation that LO loads with system start
  • unchecking antialiasing doesn’t change the problem
  • problem seems to be independent of the loaded file; the same file may appear immediately or be delayed with up to 3 minutes
  • it does not help to already have LO running with another document open or without
  • problem appears with both impress and writer (did not check the other)
  • maybe, maybe the problem is somewhat more dominant with a waggy network connection? Not sure of that, though.

I am having a very similar problem.

I have three calc spreadsheets that have external data links to each other. I understand that there might be some load on the cpu when the data exchange happens, but the load should drop back down once it’s done and that isn’t happening. Additionally, once the problem starts, it gets increasingly worse until calc suffers a creeping hang.

I can bring up any one of the spreadsheets and the problem doesn’t happen. But if I bring up two or more the problem starts and even if I close out all but one, the cpu usage continues to creep higher. I have to close out all spreadsheets, even those not involved in the data exchange before the problem clears up.

I’m using LO 7.04 64 bit on Windows 10. I have tried all of the suggested solutions above and while some seemed to help at first none of them eliminated the problem.

I have not noticed any additional memory usage or other resources, only creeping cpu usage. That peaks out at about 30%, but calc stops.

The problem does not seem to be limited to Calc, even Writer and Impress are as slow. Files that couldt be opened without problems with earlier versions now show a lag of several minutes; no joking, I sometimes manage to make tea untill LO has opened the file. The funny thing: the same file on Linux Ubuntu 20.04.2 with LO 6.4.6.2 does not seem to have problems with the same files. Any suggestions?

Some more observations: the problem is exclusively related to files in Open Document format. If I convert a file to the corresponding Microsoft format, they load without any relay immediately.
I could reproduce that with *ods-, *odt- and *odp-files and with LO-versions down to 6.4.6.2 on Windows 10. No such problem with LO 5.0.3.2 on Windows 7 or on Linux Ubuntu 20.04.

And no such problems when the network connection is stable, meaning when I sit inside the corporation’s network and not being connected via a VPN-tunnel.
And, funny enough, no problem without any network, meaning when I disconnect. That test is, however, only done with LO v 6.4.6.2

I can confirm that the delay is related to Open Document formats only. Here are the repro steps for a simple presentation without heavy content (no images, just headlines):

  1. Create a new Impress presentation
  2. Add slides
  3. Store as *.odp
  4. Navigate through slides (e.g. via Page-Keys) → delay between slides changes around 2-3 seconds
  5. Save the presentation as *.pptx
  6. Navigate through slides → no noticeable delay

Files are local, no network involved running LibreOffice 7.1.1.2 on a Linux system.

Update: the application is a bit more responsive when changing through slides in the “Notes” view, but lacks massively in “Normal” and Presentation Mode (F5).

After downloading LO 7.1.2.2 the delay seems to have disappeared, at least when having a stable network connection.
Will try with a shaky one next week.

Pity: now trying over a mobile network and a VPN tunnel, the delay is back. And if I cut the connection (disable the wireless card), the delay disappears immediately, reappearing when I reactivate the network interface. What is happening here?
I can not reproduce the problem on my Linux system, however, my Linux computer is my private, so I cannot connect that computer to the hospital’s network. However, I use the same mobile connection.
Is it possible that LO is reading or sending something over the network when it is available, and that that is the factor slowing it down? It obviously works without that, because without a network connection it works immediately…