LibreOffice Calc deletes date and replaces it with ###


Whenever I try to write “Thu 19/05/22” in a cell LibreOffice Calc reformats it as “05/19/2022” but displays “###”.
I have date acceptance patterns set to D/M/Y, and formatted the cell to “NN DD/MM/YY”.

Does anyone know how I get this to work?

Error Codes in LibreOffice Calc

The cell is not wide enough to display the contents.

1 Like

That’s it, thank you. When editing the cell the date appears as 05/19/2022, do you know if there’s a way to make it appear as 19/05/2022 instead?


Scroll down in the Link to:

“Date acceptance patterns”.


So I’ll have to change the default locale setting? Thanks

Personally, I would try adding a Date acceptance pattern first.

Just to be clear, it’s only while editing the date that it appears “backwards, as 05/21/2022”. When I hit enter it shows up as Sat 21/05/22 (cell formatting), and I have D/M/Y set under date acceptance patterns

Tools>Options>LanguageSettings>Locale (2nd setting on that page) can be used to switch from English (USA) to English (UK, Australia or whatever). This affects all dates and numerals in the whole office suite but no text (e.g. for spell checking). If you want D/M/Y dates with $ currencies, Australian English might be a good choice.
If you want to change this for one spreadsheet document, change the number format locale of the cell style named “Default”.

1 Like