LibreOffice Calc, Link to External Data and Windows XP


I am using Windows XP Professional Service Pack 3, LibreOffice Calc, Hyperterminal, and Arduino Uno to log temperature data. All programs appear to be functioning correctly independently, however when I use Calc to access data from a Hyperterminal text file that regularly updates, it’s almost like XP does not allow Calc to access the file. Calc can “see” the text file created by Hyperterminal and set up comma separated columns for data, but when I try to actually use it, the OK is grayed out, no columns are seen, and and of course nothing happens.

I am currently using Windows 7 Ultimate Service Pack 1 and Windows 10 Home respectively on two other computers with LibreOffice Calc and CoolTerm for Windows, and everything works correctly to log data into LibreOffice Calc. I used LibreOffce version because higher versions do not load on Windows XP, and went back to Hyperterminal because of issues with CoolTerm and Windows XP.

Does anyone know if there’s a security setting or something like it in Windows XP that prevents LibreOffice Calc from actually using the “Link to External Data” feature to an updating text file? It does not appear to make any difference if the text file is open or closed. I’ve tried using and after the browsing to the file name, but get the same result – grayed out “OK”, and no data into Calc.

I am strongly considering removing Windows XP, installing Linux Ubuntu, and associated Linux versions of LibreOffice, Arduino IDE, and a terminal program.

Thanks in advance for your help.

used LibreOffce version because higher versions do not load on Windows XP,

Hmm - i got:

Version:, Build ID: c838ef25c16710f8838b1faec480ebba495259d0
CPU threads: 1; OS: Windows 5.1; UI render: default; Locale: de-DE (de_DE); Calc: group

on my old XP test system, which is also backed up by the information at Documentation/System Requirements - The Document Foundation Wiki

Anyway - do I understand the question right, that you do:

  • Sheet -> Link to External Data
  • Click button Browse
  • Selecting a comma separated text file from your local file system


Maybe the file it’s already open when calc try to access it by the app that writes on it.

@mariosv - If the procedure is verified, then IIRC this did not work with csv files in LibreOffice version 5. See tdf#114995 - Link to External Data doesn’t support Text Import from CSV and fixed for 6.1.0 +

To Opaque,

Yes, I followed that procedure. As I said, it works on two other computers using different operating systems, (and different versions of Libre Office Calc.)

Calc can actually “see” the text file, but does not populate the spreadsheet with the text file data. I have also tried Excel with similar results using PLX-DAQ; the file is recognized, but the spreadsheet is not populated with corresponding data. I’ve used PLX-DAQ successfully since 2018 with Excel on Windows 10 Home.

I’ll try Open Office version - Thanks.


according to your confirmation of the procedure described in my comment above, the answer is:

You can’t perform a “Link to External Data” using LibreOffice version 5, if the the link is a txt/csv file. This functionality has been implemented through enhancement request tdf#114995 - Link to External Data doesn’t support Text Import from CSV and is available for LibreOffice version 6.1 and higher only.

Hope this answers your question.

Thank you.

I read the bug description - it sounds exactly what I’m seeing, so I’ll go the Linux route. By the way, I tried installing Libre Office version, but received a “This installation package is not supported by this processor type. Contact your product vendor.” error message. Version installs successfully on this version of Windows XP.

Thanks for your help.