LibreOffice can see my Thunderbird S/MIME keys but not my OpenPGP keys.

When attempting to sign a document, LibreOffice can’t see any of my OpenPGP keys. Seahorse sees them fine, as does Enigmail in Thunderbird. I installed Kleopatra to see if I had better luck there and before restarting the system Kleopatra could only see my public keys, but after restart Kleopatra is functional as well. Based on that particular interaction I’m wondering if LibreOffice simply can’t see the private keys for some reason. Starting the certificate manager works both with Kleopatra installed and without (in which case Seahorse starts).

For what it’s worth, I see no activity from gpg’s log (even at guru level) when interacting with libreoffice in any way. I tried setting the certificate path to my .gnupg directory just in case, and that worked just as little as expected. Of note though, -if- the first launch of kleopatra is done through the “start certificate manager” button, despite seeing gpg activity it shows no keys. That said, I still can’t work out what’s causing the issue. I’ve been trying to troubleshoot this on and off for about three days now, but I’m pretty much out of ideas. If anyone has suggestions, I’d love to hear them.

Linux Mint 19
GnuPG 2.2.4

Same problem here!