Libreoffice does not recognise my printer

As I am new here please have a little patience if I don’t post exactly the way it should be done. I’m learning!

The Problem
I have newly installed the latest versions of Ubuntu and Libreoffice since which Libreoffice does not recognise my printer which has also been re-installed. This was not the case with previous versions.

The Environment
Computer: CSL Tower with 8 Gb RAM and 1 Tb Harddisk and AMD® A8-7600 radeon r7 Processor
Operating system: Ubuntu 22.04.3 LTS which has been newly installed followed by the printer followed by libreoffice.
Libreoffice v.
Printer: Brother MFC-J6520DW with all drivers downloaded from the Brother website.

First of all, other software recognize the printer including XSane.
Attempts to print any type of document show only the “Generic printer” and that doesn’t work either!

Has anyone experience with this and perhaps tips as to how I can solve this (MEGA) problem?

Have a good day and happy computing!


As far as I know, LibreOffice never recognizes any printers. It uses the ones that are offered by the OS. Even if this is a Linux PC, I would simply try a reboot.

1 Like

Hi Villeroy,
Thanks for the quick reply. Unfortunately, it didn’t help because:

  1. Reboot is something I have already tried, without success.
  2. The printer is visible for other software through the OS, just not Libreoffice.

I would incriminate drivers coming from Brother site. I am always suspicious with such drivers because most manufacturers are rather inclined to Windows and eventually MacOS market. Have you tried to install CUPS printing manager instead?

Is this one of the versions putting LibreOffice in a Snap/container? If yes, is the container allowed to see the printer ?
Workaround: Create a pdf, then print the pdf…

Since 13 years I made only best experiences with print/scan drivers by Brother. For any Brother device, you download the latest version of the same shell script, run it as root, specify model and location, confirm eula and the script downloads/installs a combination of Debian packages. The automatically installed CUPS driver for my MFC-2710 printers works like this: You print something and the driver prints empty pages until the paper tray is empty or until you cancel.

Hi ajlittoz,
The printer is already as CUPS installed, if that is what you mean:

sudo cat /etc/cups/printers.conf
[sudo] Passwort für nicholas:

Printer configuration file for CUPS v2.4.1

Written by cupsd


NextPrinterId 23

PrinterId 21
UUID urn:uuid:e66270cc-1b52-3cbc-6b52-f4627f41c69f
AuthInfoRequired none
Info Brother_MFC_J6520DW
MakeModel Brother MFC-J6520DW, driverless, cups-filters 1.28.15
DeviceURI implicitclass://Brother_MFC_J6520DW/

Thanks for your support :smile:

Hi Wanderer,

Yes, they have moved just about everything into the snap directory.

The workaround to create a pdf and then print that worked :partying_face:
Do you have any ideas how I can solve the original problem?

Thank for your help,

How can I see if the snap/container is allowed to see the printer?

OK. I’ve found the answer to this question:

But I still haven’t worked out how to give the libreoffice snap access to the Brother directory which, stupidly enough, is installed in the Downloads directory :frowning:

That would seem, logically, to be the answer.

I avoided Snap, appimage etc. because of this and other problems, but as you are not the first the topic can be found via google:

I don’t think this is necessary. I hope the Brother-driver will be announced to the system by Cups. The time where I’d redirect to a lpr command in a special folder should be long forgotten… But downloads-folder is not the best place. Check if it really installed there or only your downloaded installer-script is there.
Things seem a bit complicated…
Maybe you don’t need cups-control…

Hi Wanderer,
Thanks for your comments, I can’t work on this anymore today but I’ll look at it again tomorrow and let you know what happens.

Hi Wanderer,
Just come back from a weekend in the mountains which is why I couldn’t work on this until now.
Your post " Application installed as snap package can’t see printer"
pointed me in the right direction where I found information on “snap packages”.
After reading the pages “Snap Tutorials | Snapcraft documentation” I found a way to connect libreoffice with the cups snap using the terminal:

$ sudo snap connect libreoffice:cups-control :cups-control

Since then libreoffice has been able to access my printers.

This is perhaps not the most elegant way to solve this problem but, for me, by far the easiest.

Many thanks for your help!