Libreoffice freeze when trying to open Tools>Options on linux

Hi,

When I’m trying to open tools>options, libreoffice freezes for no apparent reason.

I’m using fedora linux 40 Workstation on wayland on a framework laptop 13 (AMD cpu).

This bug also happened on fedora 39, and I tried installing libreoffice as an rpm, and a flatpak (flathub), and the issue is still there. It happens in all libreoffice apps.

Opening libreoffice in safe mode and deleting user config doesnt appear to do anything. When launched from the command line, libreoffice does not print anything but "failed to open display’

Other than this problem, libreoffice works normally.

Thanks for answers.

Which desktop manager? Gnome, KDE Plasma, …
Wayland causes problems on my Fedora 40 KDE Plasma with an nVidia GPU but this is not specific to LO.
Does it still happen when you restart in safe mode? How did you “delete user config”? Manually deleting ~/.config/libreoffice or using LO?

Which desktop manager? Gnome, KDE Plasma, …

Its fedora workstation, so this is gnome

Does it still happen when you restart in safe mode?

Yes, it does

How did you “delete user config”?

I deleted manually, and then using libreoffice

what version of LO ? :thinking:

can you try in command line to see if there’s any log before the freeze ?
does LO uses CPU ?

Start LO from the command line, call the options dialog and look out for “last words” on terminal.
Can you try with X11 instead of Wayland?
There is a good chance that the problem goes away when you start the program like this:
SAL_USE_VCLPLUGIN=gen libreoffice24.2 which starts LibreOffice with its native widgets, disregarding GTK. GTK and LIbreOffice are not perfectly compatible to each other.

24.2, but it also happened with the older version from fedora 39

There is no log, and LO does not use CPU

On X11, LO does not open a window

Thanks, but it does not work, there is still the freeze.

There is no log on the terminal other than “Cant open display”. Maybe you know if there is an option to enable verbose logging ?

Which, if any, of the Skia options are activated? You might try playing with them. Some graphics chips still cause issues when Skia is activated.

Hi, I am having the same problem as you do. Also running Fedora 40. Did you figure it out?

@Veg_librarian
Please give more details about your configuration: desktop manager (Gnome, KDE Plasme, Xfce, …)? Exact LO version (best: copy information from Help>About LO), nVidia graphics card?
Does it happen in another user? Eventually, create another user on your machine to check.

Hi I am running Fedora 40, so it means GNOME. Version of LO:Version: 24.2.3.2 (X86_64)
Build ID: 420(Build:2)
CPU threads: 4; OS: Linux 6.8; UI render: default; VCL: gtk3
Locale: en-US (en_US.UTF-8); UI: en-US
Calc: threaded

graphic card: Intel® HD Graphics 520 (SKL GT2)
creating a new user on my machine does seem to work. But that is not ideal solution for me.

This is not automatic. I chose KDE Plasma.

This was suggested only to see if your issue is related to some corrupted configuration in your preferred user. This seems to answer positively.


Consequently, rename ~/.config/libreoffice/4 to something like ~/.config/libreoffice/backup4 and relaunch LO. All your customisation has of course disappeared but is not lost. Does the problem still happen?

If you have “beloved” customisations you’ll like to recover, try to copy one by one the files and directories in ~/.config/libreoffice/backup4/user onto the corresponding one in 4/user, testing for the problem after each copy operation. Don’t forget to quit LO before copying.

You’ll discover which component of the user profile is responsible.

Hi, thanks for your help, unfortunately renaming the libreoffice config files as you have suggested does not help. LO will still crash. Tried safe mode, crashes too.

I discovered there is also a ~/.config/soffice.binrc but its contents looks “innocent”. Delete it or rename it and see what happens.

Other that that, look into .local to see if some LO-related file is in there. I didn’t find any in my account but who knows?

I also had this issue with Fedora 40. Gnome. Wayland. Stock install with Fedora. AMD CPU and GPU. Stock drivers. Version 24.2.3.2 (X86_64). Linux 6.8. UI render: default; VCL: gtk3. Locale en-US.UTF-8. Pretty stock system.

When I open Tools > Options it freezes give me the standard force quit or wait question. I wait and after about 15-45 seconds it will finally actually open. Fully functional. I can change settings and save. But slow to open up each time. Very repeatable…this happens every time. I have the gnome setting to attach modal dialogs to parent window. I turned it off and and tried again with same result.

I looked in logs and this only thing that I can see that may be helpful is this.

Sender gnome-shell
meta_window_set_stack_position_no_sync: assertion ‘window->stack_position >= 0’ failed