LibreOffice freezes at start on Ubuntu 20.04 when other pdf readers are installed

AMD Phenom4
8GB memory
Ubuntu 20.04.03
GeForce EN9600GSO video card
LibreOffice just updated on Dec 28, 2021 to

I have an issue with LibreOffice and at least two pdf readers FoxIt and PDF StudioViewer

Whenever I have a pdf reader installed other than the default Ubuntu reader, the computer freezes when I try to open LibreOfficeCalc.

I arrived at that conclusion by doing the following:

start the computer
Open Vivaldi and Thunderbird
then opening one program at a time, I do something with it and then I close it, everything works fine until I get to LibreOffice the computer locks up (mouse still works), wait for 30 mins until it unfreezes and restart computer.

Next time I repeat Vivaldi and Thunderbird every program one at the time, skipping LibreOffice and open Foxit, computer locks up.

Removed Foxit and reboot, repeat process and LibreOffice opens immediately no issues. Blaming FoxIt found PDFStudioViewer and repeated above process and LibreOffice freezes computer again. Removed PDFStudioViewer rebooted and LibreOffice works fine.

Not a very scientific method. I noticed in the log that file a failure was logged [TTM] Buffer Eviction Failed. This failure was logged at the time I was opening LibreOffice.

I have a laptop with Ubuntu 20.04 and Foxit and LibreOffice works fine there. I was blaming the video card because of the freeze I thought that for some reason my monitor was overtaxing my old computer, but Ubuntu 18.04 works fine and Windows works fine at 2560x1440 resolution.

Any suggestions would be appreciated.
Thank you.

After 5 more hours of use, I tried to download a LibreOffice .ott file 1cm, and the computer started to freeze again on and off for 23 minutes. I changed one of the monitors resolution to 2048x1156 and continued to use the computer for a while.
Log files showed that at 2:25 when the computer froze tracker-extract.service: Succeeded and a some 'org.freedesktop.Tracker1.Miner.Extract" were being requested at that moment.
Hope this helps.

Can you add to your good description a little:

  1. Did you update either Ubuntu or LibreOffice, when before that you had both in possibly older version and everything worked?
  2. Have you tried starting LO without a profile? (LibreOffice user profile - The Document Foundation Wiki)

Thanks Joshua for your reply.

This is a fresh Ubuntu install.

LibreOffice was locking up with whatever version came with U20.04, I just upgraded it yesterday Dec 30, 2021 to the latest

I cannot try it in safe mode since I really cannot open LibreOffice. The computer locks when I click on the LibreOfficeCalc launch icon. I do not use anything special, yesterday was the first time that I tried to download a template. I just create Calc files to keep track of house expenses and miscellaneous things, with charts. I will give the manual procedure a try and will post.

Dec 31, 2021 @ 10:30am

I logged in Ubuntu 18.04, same drive as Ubuntu 20.04 just used for testing crashes
Resolution 2560x1440
Ubuntu 18.04.05 LTS
Graphics NV92
Gnome 3.28.2
Linux Kernel 4.15.0-158-generic x86-64
LibreOffice, Build ID 1:6.0.7-0Ubuntu.18.04.10

Everything worked fine no Foxit installed.

Installed Foxit

Restarted computer

Opened the usual suspects Vivaldi, Thunderbird no issues
Opened LibreOffice Calc → no issues
Opened LibreOfficeWriter → no issues
Opened Foxit → no issues

Did an Ubuntu SW update, new kernel is 4.15.0-163-generic
Restarted computer → no issues
Open all the same programs → no issues

Used computer until 3:00pm without a problem.

One issue that I should mention is that for whatever reason it seems to me that when I use in Ubuntu 20.04 the higher resolution (2540x1440), that is when the issue happens. If I use the lower one 2048x1152 everything works normal. I have seen errors like EE Modeset(0): Failed to make 2562x1415x32bpp GBM bo, I do not understand this since the one monitor is running ok at 2540x1440.

I have log files if they are helpful.

Thanks again

I do not understand. It sounds like under certain conditions you can launch LO (with certain graphics modes or by not installing certain other software). The idea would be to get to those conditions then reset LO user profile. The site also shows that you can delete the profile in

/home/< user name >/.config/libreoffice/4/user

You could aslo try something like starting LO from terminal using something like

SAL_USE_VCLPLUGIN=gen /opt/libreoffice7.2/program/soffice

The point is that the Visual Class Library talks to some graphics system working with Ubuntu. The other installations might be installing and talking to qt5 or something, but LO is having a problem with the changes made by that installation. So you try to get it to go in as generic a way as possible to troubleshoot.

Have you simply tried to re-install LO?

Jan 1-5, 2021

All the tests from here on are without any extra pdf installed. I concluded after working for a couple of days and getting the computer locked that it is not the pdf readers what is causing the problems.

I renamed the user folder to user-old started LO and after opening the files it froze.

Looking at the log file with the frozen timestamp there were errors like:

audit: type = 144 audit (1641321892.465.95): apparmor= “ALLOWED” operation = “file perm” profile = libreoffice.oosplash and 5 more with libreoffice in it, also [TTM] Buffer eviction failed.

I could not run your suggestion of SAL_USE_VCPLUGIN= gen opt/libreoffice7.2/program/soffice that directory did not exist. All I have in opt is Vivaldi.

Restarted LO in Safemode open one of the odt files it was fine, then tried to open the other one then it froze.

Completely removed LO with apt-get remove – purge. then clean and then autoremove, then reinstalled LO from snap

Opened File1 → OK
Opened File2 → Locked,
Reboot repeat same

Unpluged second monitor (video cable), maybe trying to blame too much load in video card


No Vivaldi or Thunderbird

Opened File1 → ok
Opened File2 → ok
Closed files 1 and 2
Opened Vivaldi repeat and everything is ok.

Repeat opening Thunderbird and everything ok

Connected 2nd monitor, repeat, computer locks when opening File 2

Waited until computer unlocks then moved LO window to 2nd monitor, closed both LO calc docs,

Opened LO
Opened file1 → ok
Opened file2 → ok

Today Jan 5

Started computer, no Vivaldi or TB

Opened LO (it opened in 2nd monitor)
Opened file1 → ok
Opened file2 → ok

Now moved File1 to 1st monitor → ok
Closed file2 in 2nd monitor and reopened → ok, it reopened in 2nd monitor
Moved file2 to 1st monitor, when trying to close file2 in 1st monitor computer froze.


Opened LO → it opened in 2nd monitor
Opened file1 →ok
Opened file2 → ok
Moved file1 to 1st monitor didn’t use full screen, just half →ok
Moved file2 to 1st monitor didn’t use full screen, just half →ok
Closed file2 and reopen → ok

Tried to open LOWriter, just clicked on icon and computer froze.


Opened LOWriter
Opened LOCalc
Opened file1 and 2→ok (half screens in monitor 1)
Opened writer document→ok (full screen in monitor 2)

From all this it seems that LO does not like the full screen resolution of Monitor 1 (ASUS ProArt PA278QV, 2560x1440) or so it seemed, because when I tried then to open Vivaldi the computer froze. When it unfroze, 1 min later, I clicked in the LOWriter document and I got logged out of Ubuntu to the log in screen.

Reset again

Open only LOWriter to write this confession.

I think that my next step will be to do a full reinstall of Ubuntu, maybe 21.04.

Thanks for reading all this.

Do any other programs ever freeze?

Go to Tools-Options-LibreOffice(at left)-Paths and look at the internal paths. The first part of these paths will likely reflect your installation directory, so you can try cd’ing to these and hunting down soffice, then try that with the “prefix” (the SAL_USE_VCPLUGIN=gen).

Another idea would be to go to and try installing the LibreOffice flatpack. TDF sort of downplays this, but the current version is there.

No nothing else freezes.
I have been using the computer since I posted the previous reply 3h ago without any issues. Just opened LOWriter and did not freeze. I will try the paths. I can see them now
/my home_dir/snap/libreoffice/239/.config/libreoffice/4/ and
/snap/libreoffice/239/lib/libreoffice/program and run/user/1000/snap.libreoffice if SAL_USE… does not work then I will try the flatpack.
Found the soffice in /snap/libreoffice/239/lib/libreoffice/program. I’ll try it tomorrow.
Thanks for your help.

Oh, it looks like you have a snap installation to begin with. You might go to TDF and install the normal Ubuntu version. Download LibreOffice | LibreOffice - Free Office Suite - Based on OpenOffice - Compatible with Microsoft.

I tried the flatpak and it still crashed. Could not locate the soffice with this install.
I installed directly from a deb.tar.gz downloaded from the TDF and crashed.
With this install I was able to run the SAL_USE_VCLPLUGIN=gen /opt/libreoffice7.2/program/soffice exactly as you typed it. IT WORKS !!!
In the window ABOUT Libre office in the user interface it says
UI Render: default; VLC:x11.
It looks weird (like an old HP signal analyzer that I used to use back in the early 2000s), but it does not crash at all. I opened it and closed it twice and it works. It opens in the first monitor full screen without a problem.
I will play with it more. I was ready to give up. Still I have another SSD, will do a fresh Ubuntu install pretty much make it look like this SSD, same programs, etc and see what happens.
I hope that I do not have to keep using forever the SAL_USE_VCLPLUGIN=gen command, but whatever it takes.
Thanks again for your support.

1 Like

Jan 8, 2022
I think that I need to change the post, since I was able to duplicate the problem without any pdf readers installed. The problem seems to be related to opening LO at full resolution 2560x1440. When I open LO at any other resolution or if I open LO at half screen it does not crash. How do I update the post?

Here is the latest and this item maybe can be closed.
I did a fresh installation of Ubuntu 20.04, nothing in it just what the download installed.
I tried to open LibreOfficeCalc and the computer froze.
I tried to change the HW driver from Nouveau to NVIDIA and got an error. I did a search on the internet and found that when a kernel update happened from 5.4 (original U20.40) to 5.11 the Nvidia driver cannot be installed and if installed then the computer will not work.
Then decided to go to my old Ubuntu 20.04 install and check to see if I could change the video card driver. I was able to change it and LibreOffice does not crash. I tried in the past to upgrade the kernel from 5.4 to 5.11 and for whatever reason did not work (I am glad now). I read that 5.11 fixes a nasty security problem that is why I tried to do the update. See here Ubuntu 21.04 and 20.04 LTS Users Get New Linux Kernel Security Update, Patch Now - 9to5Linux
To summarize,
LibreOffice freezes my computer when using Nouveau driver and try to open in full screen @ 2560x1440,
at lower resolution or if I open LibreOffice on in my second monitor 1680x1050 LO does not crash
LibreOffice does not crash with Nvidia driver and full screen resolution 2560x1440.
With Kernel 5.11 Nvidia driver cannot be enabled.
So is this a Nouveau problem or a LO problem?

So, really, people run with VCL as gen, I wouldn’t let that bother you. As for who’s “fault,” I think we can just say compatibility? Thanks for listing the final details. Maybe when 5.12 comes out…