Libreoffice has incorrect home directory

All Libreoffice apps are not referencing the correct home directory. Instead it creates a folder “173” under ~/snap/libreoffice/173. The Libreoffice apps think this 173 directory is the home directory. Also all .config files are saved in this snap directory instead of the users home directory. I have tried uninstalling and reinstalling LibreOffice and there was no change. I have checked permissions of all folders and files for my user directory. I also check the processes, Libreoffice is being run as my user. How can I get LibreOffice to use my users home directory like it did a couple of days ago and stop with this snap directory stuff? It’s almost like LibreOffice thinks 173 is the user.

If I try to open a file I get this error.
image description

If I try to open a blank file and save it to my home directory I get this error
image description(/upfiles/15841453629173802.png)

stop with this snap directory stuff?

You are installing LibreOffice using snap install libreoffice and now you don’t want that? If yes - the only advice could be: Don’t use snap packages, if you don’t like it. On Ubuntu you may use: sudo add-apt-repository ppa:libreoffice/ppa followed by sudo apt install libreoffice to get the most recent fresh   LibreOffice packages or download native DEB packages from directly.

Which OS? Which LibreOffice version? Permissions on `/home/joe/snap` (or did you even delete that directory)?

btw: just installed the snap version myself on Ubuntu 18:04 and the paths shown are the paths valid for the snap package and got nothing to do with what LibreOffice thinks your home directory is. The nature of snap packages is to use snapable/snapaware directories.

Thank you for your response.

OS: Ubuntu 18.04


Permissions: drwxr-xr-x 5 joe joe 4096 Mar 13 19:29 snap

I typically use the ubuntu software GUI package manager. I only use apt-get when installing something not in the package manager or in troubleshooting. What I am really confused about is that I can use LibreOffice with no problem on Monday and by Thursday i’m getting these errors. I’m at a loss for what has changed.

Note: your reply gave me an idea I removed LibreOffice through the GUI. I then added the repository are you recommend and used apt-get to install LibreOffice again. Now everything works just fine. I’m still not sure what changed but Thank you for leading me in the correct direction to fixing the problem.

1.Remove snap package (snap remove libreoffice)
2. Add repository (sudo add-apt-repository ppa:libreoffice/ppa)
3. Install Libreoffice (sudo apt install libreoffice)