Libreoffice headless not listening on port with CentOS 7.2

OS Version: CentOS Linux release 7.2.1511 (Core)

LibreOffice Version : 4.3, and 5.2.1

How to reproduce:

  • Download libreoffice:
  • tar -xf LibreOffice_4.4.5.2_Linux_x86-64_rpm.tar.gz
  • Install missing libraries
    sudo yum install libXrender libSM libICE libXext libGLU fontconfig cups-libs
  • sudo yum localinstall LibreOffice_4.4.5.2_Linux_x86-64_rpm/RPMS/*.rpm
  • /opt/libreoffice4.4/program/soffice.bin "--accept=socket,host=,port=8100;urp;" -env:UserInstallation=file:///home/centos/.jodconverter_socket_host- --headless --nocrashreport --nodefault --nofirststartwizard --nolockcheck --nologo --norestore

Expected behavior:

  • it should create a process and open socket with port 8100

Actual behavior

  • performing netstat -tulpn no process is listening on port 8100
  • if running second time just after the first it will successfully create the process and open the port
  • Wait a couple of minutes or more, run again soffice in headless mode and it will fail again
  • Tried with multiple LibreOffice versions, same result

Am I missing anything obvious? Why is it always failing the first time?