LibreOffice icons near invisible with Gnome 42 dark mode

On Manjaro Gnome, Intel hardware (Wayland is used by default) this is what LibreOffice Writer looks like:

As you can see, several icons are simply too dark to identify, you only see its blue parts.
This is after a new, clean installation of Manjaro Gnome and installation of LibreOffice-Fresh via the official repositories of Manjaro. Nothing has been tweaked or whatever, this is just default with system-wide dark mode.
Only "Breeze(SVG+Dark)` icons are suitable, but LibreOffice does not select these icons. So by default, you get near-invisble icons and most people don’t even know you have to change the icons, if they even know this is possible.

Also… on a side note, changing the icon size to small or extra-large has 0.0 effect…

There are a few solutions/workarounds for you:

  • Do not use the Dark mode
  • Try an another Theme in the LO. It may uses an another color for the Menu and Toolbar background only.
  • There are many bult-in, and optional Icon sets. You can download the optional ones for LO 7.x.x directly from the Extensions site. Try them.

As I wrote in my post, 1 icon set has visible icons. So no need to suggest other workarounds, since I already mentioned it :slight_smile:

Your first option is not possible. I cannot turn of dark mode in LO. I would have to disable it systemwide. That is not a workaround.

If LO is only targeting users that love to spend lots of time going through all settings to discover and learn they can change iconset and they have to do that… fine, but I cannot imagine targeting that small audience.

I meant to switch off it systemwide. If you want to work with LO efficiently, then IT IS a workaround. It is an easier way than to modify the source code of the LO.

You decided to use portable software. This makes system-integration harder, and the community of dark-mode users is growing, but at the moment gnome42 dark-mode IS a small audience.

Second: Maintainers configure a lot adapting LO, so this would be a good place for a setting to breeze.

With Snap and other containers this problems will increase, not decrease.

You may file this as a bug with suggestion of another default in dark-mode at bugzilla if you want this changed. But widening your imagination and some patience may also “help”. Even now not every desktop has fractions at scaling…

1 Like

Thanks. I am confused about “portable” software. What do you mean? LibreOffice is in the official repositories. I did not install a portable version. Not sure why you think that.
By default Manjaro does not use Snap or Flatpak.

I am an end-user. Comparing your workaround to changing the source code and then concluding your workaround is easier really makes no sense. Apples and pears. Sorry for going offtopic. But with your logic you would upset end-users in a real life situation…

The portable versions are for the Windows op. sys:

See the system requrements in the description. It can run on Wine on Linux. I never tried that.

I am an End User too. But I can write macros, I am using third party extensions (if I need them), and I try to set the adjustable properties for the highest efficiency. If this efficiency is available by usage of the non-dark mode, then I use the non dark mode.

The LO is a free, opensource software. There is not any official support for the free version. The forums are “users-help-users” groups. If you want a payed professional support, then you can get it: just click on the “Business users…” link, and read it:

Portable source-code. The programmers world is much easier, if you support only one Operating-System, especially considering new features.

Start LO like this:

SAL_USE_VCLPLUGIN=gen libreoffice

Not sure what this does but I’ll give it a try.

It turns off all gtk crap for LibreOffice in favour of better functionality.

LibreOffice 7.4 will include a version of Colibre specifically designed for dark themes. Kudos go to Rizal Muttaqin!