LibreOffice ignores \*UPPER switch

Hello, I’ve already had a similar problem resolved here:

Now I have a problem that .docx document field with \*UPPER switch is not converted to uppercase anymore, I can’t explain why as the .docx hasn’t changed since my last post (linked above) and it used to work with LO, I’ve updated LO already and that hasn’t solved the issue.

When I open the .docx in MS Word, the case is formatted as expected, when I check the field code, the \*UPPER switch is there, but opening the same document in LO letter case doesn’t change, I marked the field, pressed Ctrl+F9 to show the field code, it’s formatting is different than what I see on MS Word, why is that? I’m checking the exact same .docx.

MS Word field:
image description

LibreOffice field:
image description

Thanks in advance.

LibreOffice does not support Word’s field code switches.

How did it work on then? The switch could be seen in the field and it used to convert just fine but one day it stopped working on the same LO version.

How do I work around it? I can’t seem to find a way to edit in the *UPPER switch in LO field. It would be fine to format the field at least in LO as we use it for PDF conversions in our system and we need the title to be in upper case no mater what case was used for the title in our system.

How did it work on then?

It didn’t.

How do I work around it?

Use character properties - in Word it’s “All Caps”. Having a dedicated character style would be ideal IMO.

I believe You, but I can tell You that it did work for a time then stopped, I made it work myself, that is why I’m so sure of it.

Anyway, the suggestion worked, I marked my field in LO, right-clicked > Character > Character… > Font Effects > Effects : Capitals

Now at least opening the document makes the title upper case, I think I got it from here, thank You.

As Mike suggested, I made it work with Character properties.

On LO, I marked my field, right-clicked > Character > Character… > Font Effects > Effects : Capitals