LibreOffice Impress can't start from the current slides

Hi all,

I’m new to linux and libreoffice, previously I was an old user of WIndows and MS office. Now I’m trying to use impress to open my .ppt file, and to start a slideshow, yet I failed to start from the current slide.

No matter which method I tried( 1. by pressing the shortcut ‘ctrl+F5’; or 2. by clicking ‘slideshow’ tab and click on ‘start from current slide’, the slideshow will always jump back to the first slide.

My libreoffice version is Version:, Build ID: 45e2de17089c24a1fa810c8f975a7171ba4cd432
My OS is ubuntu 14.04 64-bit.

Have a hard time trying to get to the slide I want if the file is too big (something like 100 pages and you want to just show the last page in full-screen, then you have to click for 99 times or more if there’s any animation!)

I hit the same problem. I am running LibreOffice 4.4 on Macbook.

When I use “Start from current slide”:

  • Sometimes it started from the first slide

  • Sometimes it started from a slide which is NOT the current slide.

It looks like there is a bug there!

As far as I remember, the default setting in LibO is shift-F5. However you can configure it the way you want. I am using F5 to start from the current slide and shift+F5 to start from the beginning.

Tools > Customize > keyboard tab > Category > View > Function: Start from current slide / Start from first slide; here you see your current settings and you can modify it.


With Version: toolbar contains two tools: Start from first (F5) & Start from current (Shift + F5)

But you can also create a custom slideshow.

  • Menu Slide Show > Custom Slide Show
  • Click New, give a name
  • Select slides to show

To disable or enable, check Use custom slide show in the same dialog

The problem seems to be that the “start from current slide” function will start from where the “last slide show ended”, instead of from the side that I currently select. Looks like a bug to me. :frowning:

Hi - Bugs have been reported. Some are resolved, such as: #76953

One still needs information. You can complete it with as much information (system versions, LibreOffice version & settings…) to help identify and solve it : 89752

I added comments to that bug. What else do I need to do?

Thank you for that…

Pending resolution of the problem you can use the following workaround: when presenting the slide show, Right-click> Goto slide provides instant access to a slide. This technique reinforces the importance of having renamed the slides with a meaningful name …

Thanks a lot. This morning I ran Impress again, but I couldn’t repro the bug. Then I added a slide to the middle of the deck, and the problem was back. I just added the details to the bug comment.