LibreOffice Impress messes up letter spacing in Slide Show, design view looks normal

I already asked that exact question over at and was referred here in a comment. The question is reproduced below the horizontal rule.

The document in question can be downloaded from here.

On Windows, using LibreOffice, when I create a presentation using Impress, the Slide Show (F5) cuts off the bottom and top (similar to wide-screen movies) and thus changes the aspect ratio, messing up the fonts. What gets messed up in particular is the spacing between letters, which gets stretched a lot.

Here’s how it looks during creation:

Design-time view

Here’s how it looks on the screen with the preview (fine, too):

enter image description here

And now the messed up presentation as it appears on my screen (which has the same aspect ratio as our projector, 4:3):

enter image description here

I also noticed that the framing with the background you choose during initial creation of the presentation is not even shown on the last view.

How can I make sure that the aspect ratio (and consequently the inter-letter spacing and so on) remains the same, no matter what?

It would help in trying to reproduce and track the problem if you could upload that test presentation.

An attempt to upload an attachment results in SyntaxError: at index 5 in "data = ": expected expression, got <end of file>

Tested the uploaded file under GNU/Linux with LibreOffice 3.5.3 and it works fine. Try installing latest LO version as @manj_k advised.

Pretty sure → Bug 46901 - SLIDESHOW shows characters too slim with Hardware Acceleration activated - cairo canvas used in error on windows.

Please try with the current version LibreOffice 3.5.3.

Workaround for v3.5.1:

Disable hardware acceleration via

Tools → Options → LibreOffice → View → Graphic output

Addendum: Screenshot
(LibreOffice 3.5.3)

Slide Show: Untitled1.odp

Thanks, will try that. Of course disabling hardware acceleration isn’t really an option, because this machine is used for way more thing. Probably means I’ll have to ban LO into a VM in order to create and test my stuff there … :expressionless: … and btw, I can’t even upvote your answer, this is ridiculous.

Please read the bug report, fdo#46901 (regression) has been fixed in LO Hardware acceleration has not been disabled in the screenshot above.

@manj_k: I realized that when reading through the bug report, thanks. I now installed it and it works. But I still cannot upvote your answer, not even a comment. I’ll see whether I can accept it, though.