LibreOffice Impress not always saving

Hi guys,
I’ve been using LibreOffice for several years now and really enjoy using it. Recently however I have been using Impress for the first time, and while I honestly prefer it to MS Powerpoint that I am compelled to use at work, I have one issue with it. The first time this happened I thought I had neglected to save, but now can confirm this is definitely not the case.

Almost always, when I save, my Impress presentation saves just fine. However when I went back to one of my older slides, I see that the wording in the slide was incomplete (IE the end of the last sentence was truncated). I completed the sentence, and re-saved. However when I open the document, it’s back again, truncated. The only work around I found was to duplicate the slide, update the new copy, and then delete the old slide! Now it saves just fine. I thought this had solved my issue, but now I see the problem is popping up in another slide that historically was saving just fine!

I’m now concerned that I will end up losing chunks of valuable work in my presentation. Is there something I’m missing or doing wrong? Is this a known bug (I looked online but can only find similar issues with much older posts dating back to 2013/14)

The problem is repeatable, and when I find the problem, I can complete the sentence in the slide, save (and it definitely saves, as other work is saved in the document), close it. When I re-open Impress, the sentence will be truncated once more.

My computer is fully up to date, running Ubuntu 20.04, and Version of LibreOffice.
Environment states CPU threads: 8, OS Linux 5.15 (Ubuntu version 1:7.3.7-0ubuntu0.22.04.1, calc threaded)

Do you use a gradient as background image?

Then Bug:


1 Like

No, I don’t use a gradient. I do however have a background image that fills the entire window.

Upload a reduced and anonymized file here so that someone can examine it.

Otherwise, please report the behavior also as an error in Bugzilla .

See also:

How to Report Bugs in LibreOffice .

Please post the link to the bug here.
format: tdf#nnnnnn (use only the number, not the link)
To do this, edit your original question.
Thank you very much.

hmmm, For whatever reason the forum page won’t let me upload my (.odp) file. My presentation is only about 1.1MB in size, however the forum page complains that only files up to 4MB may be uploaded! I don’t have any cloud account to upload to (and then provide a link to) either, sorry.

I’ve cut my presentation right back to only 3 slides, with a few minor images and no integrated video/sound, so it isn’t very large at all.


1 Like

Close, thanks, but no. This is a brand new presentation using an up to date version of Impress. First started working on this presentation a few weeks ago.

This has nothing to tell if this is “no”. The bug manifested not because the file was “old” or created with an old version - it was because sometimes the editing session did not flush data. So the point was: you should see that it is fixed in later versions; so to check, you need to test those newer versions.

Sorry, you have lost me. If I click “Save” as I have done many times now (or CTRL+S) then isn’t that my newest/latest version? and that is what I am opening. The same file I have just saved/closed seconds ago, when I reopen it my work is gone for the slide in question. Other slides appear (for now) to remain unaffected.

Also note that even if I (first) update the offending slide, and then after that I update/add/delete/change other slides, then all the changes I have made are saved appropriately. IE I don’t lose data for the stuff I have done afterwards, which implies to me that data is being flushed appropriately, but for some reason the changes made just to that one slide in question do not stick when saved.

As stated in my original post, I have a workaround, where I can duplicate the slide, delete the old one and then edit the new one. Then it works just fine. But unfortunately then it appears the problem manifests itself for another slide further on.

You should try the newer versions of LibreOffice, not of your file. It’s new versions of program that fix bugs.

ah ok, sorry. Yes of course I realize that using the latest versions of software generally fixes old bugs (though new ones can also be introduced in the process…).
Just double checked on LibreOffice’s site (release notes) and see my version was released in December 2022, so only about 2 - 3 months old. So updates are working, but no doubt Ubuntu takes a bit of time catching up, hence why I don’t have the latest/greatest version. I’ll see if I can bump it.

If you use the default Ubuntu-repo LibreOffice, then it’s the distro policy that defines which upstream updates get into a given distro release. I.e., for a given Ubuntu version, when it was released, some LibreOffice major version was available (say, 7.3.2); and that version was initially present in the Ubuntu release. Then for this Ubuntu release, only 7.3.x updates of LibreOffice would be made available, not any later releases (7.4, 7.5, etc.).

There is a PPA from Ubuntu Packaging team, which can be used to upgrade outside of the distro policy.

And it was the last in 7.3 series. One would expect that you are not going to get more updates in your default configuration. While the bug that we discuss is fixed only starting with LO version 7.4.6 (still not released), or 7.5.0.

1 Like

Thanks @mikekaganski for the very useful information. I was wondering which release had this bug fixed, but didn’t find any release notes online (I’m sure they are there, I just didn’t go hunting around for too long).

@witenite did you read the bug Mike linked to above? All the information is in there.

Hi @EarnestAl , I did but it doesn’t sound exactly like the issue I am having. It may well be related (or having the same outcome) however that bug report talks about opening a presentation made on a slightly older version of Impress. I never did that, I am running the same version the presentation was first created on.

LibreOffice is the slightly older version referred to, see top of page, earliest affected version.

Comment 4 says is not affected

Comments further down page say which later versions have been fixed.

Also see release schedule for LibreOffice,
Cheers, Al