Libreoffice Impress won't run videos (Build ID: 400m0(Build:3)) on Ubuntu 12.10

Trying to include a video in an Impress presentation. You Insert->Movie and Sound, or you use Tools->Media Player. This lets you Open (with or without Link) a file (.avi in my case). The screen goes dim, and gives the impression that things are happening. Then a toolbar appears with a Play button (which looks suspiciously gray), but nothing happens.
Opinions seem to vary as to whether it uses gstreamer or JMF (or both). In recent days I have installed:

  • gstreamer0.10-ffmpeg (claims to support every imaginable format)
  • openjdk-7-jre
  • icedtea-7
  • jmf-2_1_1e-linux-i586

That last one is a pain, because it has to be downloaded from Oracle, and is a beast to setup.

I have included in my .profile:

export JMFHOME=/usr/lib/jvm/classes/JMF-2.1.1e
export CLASSPATH=$JMFHOME/lib/jmf.jar:$JMFHOME/lib/sound.jar

and the JMF - Diagnostics Applet produces no complaints. I even tried jmstudio, and I got the sound from my video, but it seemed to want javax before actually showin anything.

But after all that, I can still get nothing running in Impress.

What else do I need to do?

What type of video file (container and format) is it? Edit your question to include the output from the file command. Thanks.